Crystal Space
Welcome, Guest. Please login or register.
October 22, 2014, 03:24:24 am

Login with username, password and session length
Search:     Advanced search
9010 Posts in 2044 Topics by 8782 Members
Latest Member: Carleenestery0303
* Home Help Search Login Register
+  Crystal Space
|-+  Crystal Space Development
| |-+  Support
| | |-+  Compiling problems...
« previous next »
Pages: [1] Print
Author Topic: Compiling problems...  (Read 2927 times)
Lavos
Newbie
*
Posts: 4


View Profile
« on: August 20, 2008, 05:10:04 pm »

Hello there, I am a hobbyist 3d modeler and I thought about trying to make a game. I've chosen Crystal Space/Entity Layer as the graphics/game engines, and have compiled Crystal Space successfully. But, when I went to compile CEL, it simply didn't work...
It gives me the following error message during the ./configure process:
"checking if Crystal Space SDK is usable... no
configure: error:
*** Crystal Space could not be found or was unusable. The latest version is
*** always available from http://www.crystalspace3d.org/
*** Also, be sure that you have either installed Crystal Space or set the
*** CRYSTAL environment variable properly."

--The troubleshooting I've tried so far:
1.) I HAVE set the CRYSTAL environment variable
2.) I've tried to rename the folder(changing the EV accordingly)
3.) I've recompiled CS. Countless times.
4.) Started all the libs/MinGW/MSYS installing and CS compiling from scratch.

Neither worked. Unless I've done them wrong (which I doubt, because I've followed the tutorials and have already been able to compile/install CS/CEL before in another computer), I have NO idea what else to do.

I am using Windows as the OS and MinGW/MSYS to compile. All of the libs/CS/CEL versions are the latest stable ones.

PS.:Sorry about the bad grammar... English is not my native language. Just hope you guys can understand what I mean.
« Last Edit: August 20, 2008, 05:12:05 pm by Lavos » Logged
jorrit
Administrator
Hero Member
*****
Posts: 1706


View Profile
« Reply #1 on: August 20, 2008, 07:31:37 pm »

Can you tell me how you set the CRYSTAL env var? To what value is it set?

Greetings,
Logged
Lavos
Newbie
*
Posts: 4


View Profile
« Reply #2 on: August 20, 2008, 08:31:58 pm »

Through "System"/"Advanced"/"Environment Variables"
The variable is CRYSTAL(all caps), value is the same directory I've compiled CS.(C:/CS, for example).
It is set as a System Variable, not as a User Variable. I've tried doing the opposite as well, and I also have tried adding it to both User and System variables, but it didn't work in any of the previous ways.
Thanks for the attention,
Logged
jorrit
Administrator
Hero Member
*****
Posts: 1706


View Profile
« Reply #3 on: August 20, 2008, 08:33:04 pm »

For MSYS you must use MSYS notation. That means the environment variable should be /c/CS and not c:/CS or c:\CS.

i.e. use forward slashes and use /c instead of c:

Greetings,
Logged
Lavos
Newbie
*
Posts: 4


View Profile
« Reply #4 on: August 20, 2008, 08:43:01 pm »

It worked! I can't believe it!
Thank you VERY MUCH, jorrit!
Logged
Pages: [1] Print 
« previous next »
Jump to:  

Powered by MySQL Powered by PHP Powered by SMF 1.1.2 | SMF © 2006-2007, Simple Machines LLC Valid XHTML 1.0! Valid CSS!
Page created in 4.165 seconds with 15 queries.