Crystal Space
Welcome, Guest. Please login or register.
November 26, 2014, 03:24:35 pm

Login with username, password and session length
Search:     Advanced search
9026 Posts in 2046 Topics by 9140 Members
Latest Member: Corrycrifford
* Home Help Search Login Register
  Show Posts
Pages: [1]
1  Crystal Space Projects / Project Discussion / Web plugin for viewing walktest with levels on: June 12, 2006, 09:16:51 pm
Has anyone thought of creating a web based plugin for viewing levels created in Crystal Space?? The idea came to mind, from when our lovely friends at Blender.org created a web plugin for version 2.23 (I think, or was it 2.25??) for Blender3d.? Was kinda cool, but they discontinued it.? Don't know why...

However...in the construction industry, I can take our dxf or VRML drawings of buildings and make them "cosmetically" look better in blender3d.? Then, use our blender2crystal export script to view in walktest.? Then, posting the veiwable levels online for customers, such as school systems, goverment facilities, public parks, would be a great marketing move.? They would use the walktest to walk through the building, up and down stairs, elevators, and maybe do things like turn off/on lights.? Taxpayers love to see what there taxes are building, at least here in the U.S.

If anyone is intrested, I'll team up.? Shoot me a mesage...

-krolrules



2  Crystal Space Development / Game Content Creation / Re: Blender2Crystal - textures not showing on RUN on: June 09, 2006, 12:36:25 pm
Here is what I figured out last night --

After selecting the image to put on the face, I have to selet the "Pack/Unpack" icon in the UV editor.  Then, I had to select it again, and choose "Create //texture/tex1.jpg."  Seems like this puts it into the VFS.  Runs and looks great now.

3  Crystal Space Development / Game Content Creation / Blender2Crystal - textures not showing on RUN on: June 08, 2006, 06:23:15 pm
Blender 2.41
Python2.4
Blender2Crystal

I successfully export and run a world using Blender 2.41.? Of course, without putting textures on my meshes, I get the checkerboard texture look in walktest.? That's ok, because I didn't apply textures yet.

Soooo, from there, I tried to apply textures to my map using the UV editor.? (from a wiki article on blender2crystal).? The textures get applied successfully, and I can see them in my textured windows in Blender.? However, after running the exporter, my walktest command window says, for example, "could not open image file "textures/tex.jpg" on vfs!"? ..and the image of course does not show and I get the checker default image applied instead.

I'm thinking for some reason the blender2crystal exporter is not putting the texture in the vfs, or zip file for the world.? Any thoughts on how to fix this, or do I have the exporter not configured right?
Pages: [1]
Powered by MySQL Powered by PHP Powered by SMF 1.1.2 | SMF © 2006-2007, Simple Machines LLC Valid XHTML 1.0! Valid CSS!
Page created in 3.152 seconds with 17 queries.