Crystal Space
Welcome, Guest. Please login or register.
July 31, 2014, 12:25:02 am

Login with username, password and session length
Search:     Advanced search
9005 Posts in 2043 Topics by 8260 Members
Latest Member: Lovelymae39
* Home Help Search Login Register
+  Crystal Space
|-+  Crystal Space Development
| |-+  General Crystal Space Discussion
| | |-+  stencil shadow problem
« previous next »
Pages: [1] Print
Author Topic: stencil shadow problem  (Read 2875 times)
rsc
Guest


Email
« on: May 12, 2006, 08:45:59 pm »

hi everyone,
i have a big problem with stencil shadow...when i make a map with shadow (or shadow2) renderloop all object take green, red or blue halo...i try to add a texture with property NOR but all object turn dark and shadow are not visible. Other problem is that the texture that i use as NOR appears and disappear when i move the camera.
somebady can helps me?thanks
Logged
jorrit
Administrator
Hero Member
*****
Posts: 1706


View Profile
« Reply #1 on: May 13, 2006, 08:46:29 am »

hi everyone,
i have a big problem with stencil shadow...when i make a map with shadow (or shadow2) renderloop all object take green, red or blue halo...i try to add a texture with property NOR but all object turn dark and shadow are not visible. Other problem is that the texture that i use as NOR appears and disappear when i move the camera.
somebady can helps me?thanks

What Operating System, 3D card and drivers are you using? Did you try updating your drivers recently?

Greetings,
Logged
rsc
Guest


Email
« Reply #2 on: May 16, 2006, 08:04:01 pm »

i use win xp (pro edition i think) ati 9600 (by sparkle) and lastest driver....i use the last CS edition and i try to download the daily binaries generated but nothing change....


Logged
rsc
Guest


Email
« Reply #3 on: May 17, 2006, 04:49:51 pm »

this is the result of "-verbose=-vsf"

"csDetectDriver: monitor name is '\\.\DISPLAY1'
csDetectDriver: driver name is 'ATI2DVAG'
csDetectDriver: found DLL 'atioglxx.dll'

crystalspace.canvas.openglwin:
  GL driver: atioglxx.dll 6.14.10.5757

crystalspace.canvas.openglcommon.driverdb:
  Applied: ATI: Can't handle GL_BLEND texenv for GL_INTENSITY textures
  Applied: ATI: Can't handle compressed formats for RECT textures
  Applied: ATI: RECT texture extension support apparently sucks
  Applied: ATI: Use AFP for some 2D drawing

crystalspace.canvas.openglcommon:
  OpenGL renderer: RADEON 9600 XT x86/SSE2 (vendor: ATI Technologies Inc.)
  version 2.0.5757 WinXP Release
  Using windowed mode at resolution 800x600.
  Pixel format: Color: 32 Alpha: 8 Depth: 24 Stencil: 8 AccumColor: 0
  AccumAlpha: 0 MultiSamples: 0

crystalspace.canvas.opengl.extmgr:
  GL Extension 'GL_ARB_multitexture' found and used.
  GL Extension 'GL_ARB_texture_env_combine' found and used.
  GL Extension 'GL_ARB_multisample' found and used.

crystalspace.canvas.openglcommon:
  Multisample: disabled

crystalspace.canvas.opengl.extmgr:
  GL Extension 'GL_ARB_fragment_program' found and used.

crystalspace.canvas.openglcommon.fontcache:
  Text drawing method: ARB fragment program

crystalspace.canvas.opengl.extmgr:
  WGL Extension 'WGL_ARB_extensions_string' found and used.
  WGL Extension 'WGL_EXT_swap_control' found and used.

crystalspace.canvas.openglwin:
  VSync is disabled.

crystalspace.canvas.opengl.extmgr:
  GL Extension 'GL_version_1_2' found and used.
  GL Extension 'GL_ARB_texture_cube_map' found and used.
  GL Extension 'GL_EXT_texture3D' found and used.
  GL Extension 'GL_ARB_vertex_buffer_object' found and used.
  GL Extension 'GL_SGIS_generate_mipmap' found and used.
  GL Extension 'GL_EXT_texture_filter_anisotropic' found and used.
  GL Extension 'GL_EXT_texture_lod_bias' found and used.
  GL Extension 'GL_ARB_point_parameters' found and used.
  GL Extension 'GL_ARB_point_sprite' found, but not used.
  GL Extension 'GL_EXT_framebuffer_object' found, but not used.
  GL Extension 'GL_ARB_texture_rectangle' not found.
  GL Extension 'GL_EXT_texture_rectangle' found, but not used.
  GL Extension 'GL_NV_texture_rectangle' not found.
  GL Extension 'GL_ARB_vertex_program' found and used.
  GL Extension 'GL_EXT_secondary_color' found and used.

crystalspace.graphics3d.opengl:
  Maximum texture size is 2048x2048

crystalspace.graphics3d.opengl.vbo:
  Setting up VBO buffers, VB: 32 MB IB: 16 MB

crystalspace.graphics3d.opengl:
  Stencil clipping is used for objects >= 50 triangles.
  Clearing Z buffer when stencil clear is needed enabled

crystalspace.graphics3d.shadermgr:
  Loaded compiler plugin crystalspace.graphics3d.shadercompiler.xmlshader,
  compiler: XMLShader

crystalspace.canvas.opengl.extmgr:
  GL Extension 'GL_ARB_texture_compression' found and used.
  GL Extension 'GL_EXT_texture_compression_s3tc' found and used.

crystalspace.graphics3d.opengl:
  Render-to-texture backend: framebuffer
  Delayed buffer swapping: disabled
  AFP DrawPixmap() workaround: enabled

crystalspace.graphics3d.shadercompiler.xmlshader:
  Shader std_lighting_fixed: 8 variations, 4 ms
  Shader std_lighting: 48 variations, 31 ms
  Shader std_lighting_portal: unvarying, 1 ms

crystalspace.system:
  Loading map 'c:\CrystalSpace099\world2\'.
VFS_MOUNT: Mounted: Vpath /tmp/__automount0__, Rpath c:$/CrystalSpace099$/world2$/

crystalspace.graphics3d.shadercompiler.xmlshader:
  Shader ambient: unvarying, 0 ms
  Shader light_bumpmap: unvarying, 2 ms

crystalspace.maploader:
  Could not find texture 'no'. Attempting to load.

crystalspace.maploader.parse.image:
  Could not open image file 'no' on VFS!

crystalspace.maploader.parse.texture:
  Couldn't load image 'no', using checkerboard instead!

crystalspace.system:
  Precaching all things...
  Precaching finished...
Total level load time: 0.413 seconds
  Computing OBBs ...
  --------------------------------------

crystalspace.canvas.opengl.extmgr:
  GL Extension 'GL_EXT_separate_specular_color' found and used.
  GL Extension 'GL_ARB_texture_env_dot3' found and used.

crystalspace.graphics3d.shader.fixed:
  Multitexture units: whopping 8

crystalspace.graphics3d.shadercompiler.xmlshader:
  Shader 'ambient'<0>: Technique with priority 50 succeeds!
  Shader shadowextrudeen: unvarying, 0 ms
  Shader 'shadowextrudeen'<0>: Technique with priority 100 succeeds!
  Shader 'light_bumpmap'<0>: Technique with priority 350 succeeds!
Cleaning up...
"
Logged
calli
Newbie
*
Posts: 26


View Profile
« Reply #4 on: May 18, 2006, 12:42:05 pm »

I experienced that too. I had to use Bump-Maps on all objects with textures which solved the problem.

Regards,
Carsten
Logged
rsc
Guest


Email
« Reply #5 on: May 19, 2006, 02:08:07 pm »

thanks Smiley i must use the texture with blue halo in bump maps and all works fine!
Logged
Pages: [1] Print 
« previous next »
Jump to:  

Powered by MySQL Powered by PHP Powered by SMF 1.1.2 | SMF © 2006-2007, Simple Machines LLC Valid XHTML 1.0! Valid CSS!
Page created in 5.308 seconds with 16 queries.