Crystal Space
Welcome, Guest. Please login or register.
November 26, 2015, 07:18:32 pm

Login with username, password and session length
Search:     Advanced search
9100 Posts in 2101 Topics by 10536 Members
Latest Member: 9jdw3086
* Home Help Search Login Register
+  Crystal Space
|-+  Crystal Space Development
| |-+  Support
| | |-+  objcopy crashes when compiling walktest
« previous next »
Pages: [1] Print
Author Topic: objcopy crashes when compiling walktest  (Read 2061 times)
Posts: 7

View Profile
« on: May 31, 2006, 10:48:09 pm »


i tried to compile walktest by my own on the following system:

MS Windows XP (32 bit) Prof. (SP2)
Athlon 64 X2
NVIDIA GForce 7800 GT with latest NVIDA driver

MinGW 5.0.2
MSYS 1.0.10

(cs-win32libs-0.99r0_018.exe cs-win32libs-0.99r0_020.exe cs-win32libs-0.99r0_021.exe) each time, one of them. tried all (install/compile/deinstall complete environment MingW/MSYS/cslibs)

I cleared the folder from CS and decompressed the to get a "clear" source folder without headers/dlls/etc.

At the end of "jam walktest" there is the following error:


C++ ./out/msysx86/debug/libs/csplugincommon/sndsys/cyclicbuf.o
C++ ./out/msysx86/debug/libs/csplugincommon/sndsys/snddata.o
C++ ./out/msysx86/debug/libs/csplugincommon/sndsys/sndstream.o
Archive ./out/msysx86/debug/libs/libcrystalspace.a
Archive ./out/msysx86/debug/libs/libcrystalspace.a
Ranlib ./out/msysx86/debug/libs/libcrystalspace.a
LinkApplication walktest.exe
DoSplitDebugInfo walktest.exe
...updated 240 target(s)...

Directly after

DoSplitDebugInfo walktest.exe

is printed an windows with "Objcopy.exe crashed ...." the file "walktest.exe" was created, but it is not executable. Windows "says": "this is not a valid Win32 Application" and MinGW means: "Permission denied" if i try to satrt it from there .. or within the windows command console.

Any suggestions?

Thanks in advance wink

« Last Edit: May 31, 2006, 10:50:52 pm by schorsch_76 » Logged
Posts: 7

View Profile
« Reply #1 on: May 31, 2006, 11:05:49 pm »

Problem solved ....

... the error was try to compile the current cvs version with this configuration (MinGW/MSYS/cslibs)

I compiled now the version from jan. with this tools. The cvs/svn version try i tomorrow afternoon to compile. The tools (mingw/msys) should work, the pro?er cswinlibs is the package with the numer 021?


Hero Member
Posts: 1706

View Profile
« Reply #2 on: June 01, 2006, 05:20:31 am »

Be aware that CS is no longer using CVS! The CVS version is outdated and indeed has that problem. We recently moved to SVN and in the SVN version that problem is fixed.

Pages: [1] Print 
« previous next »
Jump to:  

Powered by MySQL Powered by PHP Powered by SMF 1.1.2 | SMF © 2006-2007, Simple Machines LLC Valid XHTML 1.0! Valid CSS!
Page created in 6.197 seconds with 17 queries.