Crystal Space
Welcome, Guest. Please login or register.
September 03, 2014, 06:31:26 am

Login with username, password and session length
Search:     Advanced search
9009 Posts in 2043 Topics by 8379 Members
Latest Member: Hamlock3
* Home Help Search Login Register
+  Crystal Space
|-+  Associate Projects
| |-+  CEL Discussion
| | |-+  Unable to compile the tutorial
« previous next »
Pages: [1] Print
Author Topic: Unable to compile the tutorial  (Read 4232 times)
Almos
Newbie
*
Posts: 12



View Profile Email
« on: June 09, 2006, 07:44:29 am »

When I try to compile the CEL tutorial I get the following error:

:win32.cpp undefined reference to '_imp_GetStockObject@4'

 I'm sure that all the dependencies are set correctly.
Logged

I'm new to programming and I am making an MMORPG!
jorrit
Administrator
Hero Member
*****
Posts: 1706


View Profile
« Reply #1 on: June 09, 2006, 07:45:21 am »

It looks as if you're not linking to the win32 libraries. Can you tell me a bit about what compiler you are using?

Greetings,
Logged
Almos
Newbie
*
Posts: 12



View Profile Email
« Reply #2 on: June 09, 2006, 07:49:03 am »

I'm using MingW and Code::Blocks. I think I've ran across same problem when trying to link my first CS program as a console application - it occurs each time I try to compile the CS app this way.Now that I switched the target to GUI application it built fine.

 Thanks for the quick reply!

Logged

I'm new to programming and I am making an MMORPG!
jorrit
Administrator
Hero Member
*****
Posts: 1706


View Profile
« Reply #3 on: June 09, 2006, 07:49:42 am »

I'm using MingW and Code::Blocks. I think I've ran across same problem when trying to link my first CS program as a console application - it occurs each time I try to compile the CS app this way. I switched the target to GUI application and it built fine.

 Thanks for the quick reply!



So what libraries and other options are you using for your project?

Greetings,
Logged
Almos
Newbie
*
Posts: 12



View Profile Email
« Reply #4 on: June 09, 2006, 07:52:01 am »

I'm using all the CS static libraries and libceltool.a library. I think the issue is a minor one given that it can be fixed just by switching the target.


EDIT: All the gcc compiler options from the Code::Blocks list were disabled during the compilation.
Logged

I'm new to programming and I am making an MMORPG!
jorrit
Administrator
Hero Member
*****
Posts: 1706


View Profile
« Reply #5 on: June 09, 2006, 07:52:49 am »

I'm using all the CS static libraries and libceltool.a library. I think the issue is a minor one given that it can be fixed just by switching the target.

You should add win32 library too. That contains those functions. Those are not CS functions but from the core win32 libraries.

Greetings,
Logged
Almos
Newbie
*
Posts: 12



View Profile Email
« Reply #6 on: June 09, 2006, 07:53:41 am »

Ok, thanks.
Logged

I'm new to programming and I am making an MMORPG!
Pages: [1] Print 
« previous next »
Jump to:  

Powered by MySQL Powered by PHP Powered by SMF 1.1.2 | SMF © 2006-2007, Simple Machines LLC Valid XHTML 1.0! Valid CSS!
Page created in 3.308 seconds with 15 queries.