Crystal Space
Welcome, Guest. Please login or register.
December 20, 2014, 02:47:20 pm

Login with username, password and session length
Search:     Advanced search
9032 Posts in 2046 Topics by 9295 Members
Latest Member: Marioibuch
* Home Help Search Login Register
+  Crystal Space
|-+  Crystal Space Development
| |-+  General Crystal Space Discussion
| | |-+  Problems with cygwin and MingW/MSYS
« previous next »
Pages: [1] Print
Author Topic: Problems with cygwin and MingW/MSYS  (Read 1957 times)
arunk
Newbie
*
Posts: 7


View Profile
« on: June 23, 2006, 03:03:11 pm »

Hi,
I had posted this in the Support section, but since I didnt get any response there, I'm posting here under Jorrits advice. There are 3 parts to the problem. Crashes under cygwin and the pseudo stable release, problems compiling using the latest SVN version. And problems with MingW/MSYS. Hopefully someone can help me out or point me in the right direction.

I have downloaded cs-win32libs-0.99r0_018.exe and copied them to all 3 copies of my CS folder and both MSYS and cygwin are correctly setup (profile sets PATH to the cswinlibs folder).
OS: Win XP Prof.


Part I: Cygwin and pseudo stable
I first downloaded the pseudo stable release cs-pseudo-stable-2006-01-27.zip. I already had cygwin on my system so I compiled with that. Everything compiled fine. The only problem I am facing is with the sample applications, some of them work, most of them crash.

For instance here is the info for walktest.exe
<walktest.exe.stackdump>
Exception: STATUS_ACCESS_VIOLATION at eip=34051EF3
eax=00000000 ebx=10226580 ecx=32C47820 edx=32C47840 esi=32C41C60 edi=00000008
ebp=0022E3A8 esp=0022E3A0 program=d:\GHQ\dev\CS\walktest.exe, pid 1572, thread main
cs=001B ds=0023 es=0023 fs=003B gs=0000 ss=0023
Stack trace:
Frame? ? ?Function? Args
0022E3A8? 34051EF3? (32C41C60, 32C47840, 00000008, 340897F8)
End of stack trace
</walktest.exe.stackdump>

Using gdb I get this:

Program recieved signal SIGSEGV, Segmentation fault.
0x34041ef3 in cspluginPNGimg::ImagePngFile::PngLoader::ImagePngRead (
? ? png=0x32810dd0, data=0x328112e0 "", size=8)
? ? at plugins/video/loader/png/pngimage.cpp:357
357? ? ? ? ? ? if (self->r_size < size)

Ones that work: simple1.exe, waterdemo.exe
Ones that crash: walktest, simple2, and pretty much everything else.

gcc, g++ version: 3.4.4

Part II: MSYS/MingW
After checking these forums I saw some posts about MingW/MSYS being preffered over cygwin, so I gave that a shot. I installed MingW first with MingW-5.0.2.exe. I selected the latest version of make and gcc.
make: 3.79.1
gcc, g++: 3.4.2

Then installed MSYS, MSYS-1.0.10-rc-5.exe.

Configure runs fine till the end, when I get an error saying can't open directory /configstat<randomchars>/jcache.
When I run jam it appears to be compiling the source, but nothing gets created. The out/debug/blahblah dont get created at all. I saw a similar post but there was no solution to this particular problem, and I think the author went and tried Visual C++ in the end. Basically the 'out' directory and all its subdirectories dont get created at all, even when I run jam -q it runs through fine. I can upload the jam output if you like.

Part III: Cygwin and SVN
I finally grabbed the SVN copy yesterday and tried compiling it on cygwin.
Here is the jam output I get:
CompileResources ./out/msysx86/debug/plugins/bugplug/bugplug_resource.o
windres: <stdin>:34: syntax error

? ? cat ./out/msysx86/debug/plugins/bugplug/bugplug_versionrc.rc ./out/msysx86/debug/plugins/bugplug/bugplug_metarc.rc | windres --use-temp-file? --include-dir=./out/msysx86/debug/plugins/bugplug --include-dir=./out/msysx86/debug/plugins/bugplug -o ./out/msysx86/debug/plugins/bugplug/bugplug_resource.o

...failed CompileResources ./out/msysx86/debug/plugins/bugplug/bugplug_resource.o ...
...skipped bugplug.dll for lack of <plugins!bugplug!>bugplug_resource.o...


Thanks for your time.
Logged
jorrit
Administrator
Hero Member
*****
Posts: 1706


View Profile
« Reply #1 on: June 23, 2006, 03:08:09 pm »

Hi,
I had posted this in the Support section, but since I didnt get any response there, I'm posting here under Jorrits advice.

I meant the mailing lists (via sourceforge). Not this forum.

Greetings,
Logged
arunk
Newbie
*
Posts: 7


View Profile
« Reply #2 on: June 23, 2006, 03:58:48 pm »

I found the lists and crystal-main. I'm waiting for the response mail. Thanks.

You can remove this post from here.
Logged
Pages: [1] Print 
« previous next »
Jump to:  

Powered by MySQL Powered by PHP Powered by SMF 1.1.2 | SMF © 2006-2007, Simple Machines LLC Valid XHTML 1.0! Valid CSS!
Page created in 4.203 seconds with 16 queries.