Crystal Space
Welcome, Guest. Please login or register.
April 19, 2014, 11:23:01 am

Login with username, password and session length
Search:     Advanced search
8990 Posts in 2037 Topics by 7597 Members
Latest Member: Drukareczka1989
* Home Help Search Login Register
+  Crystal Space
|-+  Crystal Space Development
| |-+  Support
| | |-+  problem with installation on Windows
« previous next »
Pages: [1] Print
Author Topic: problem with installation on Windows  (Read 2501 times)
Myrddin
Newbie
*
Posts: 16


View Profile Email
« on: July 01, 2006, 11:57:22 pm »

Hey guys. I used Crystalspace to make a game for my game development capstone course for a computer science degree at GVSU. Now, however, I don't really like Linux so I was trying to get the Windows version of CS installed so I can make a windows exe to showcase in my portfolio.

While installing, I installed the 0.98r004 version of crystalspace, and the 0.98r004_001 version of CrystalSpaceLib. When I attempt to compile following the manual's instructions for visual studio, when I get to "rebuild all", VS spits out two errors, .\..\include\csutil/zip.h(28) : fatal error C1083: Cannot open include file: 'zlib.h': No such file or directory
both times.

I checked, and it seems that zlib.h is included in the library I installed, so why wouldn't it register? I also found the source code myself and manually inserted the zlib.h file in the directory, but alas that didn't work either.

How can I get CS working on my machine?
Thanks in advance!
Logged
paganwarrior
Jr. Member
**
Posts: 68


View Profile Email
« Reply #1 on: July 05, 2006, 10:34:04 am »

Maybe the IDE don't see the CrystalSpace  include directories. Complier? IDE?
Logged
Myrddin
Newbie
*
Posts: 16


View Profile Email
« Reply #2 on: July 05, 2006, 02:44:16 pm »

Maybe the IDE don't see the CrystalSpace  include directories. Complier? IDE?

Wouldn't everything else not compile though, not just those two classes in regards to a single file?
Logged
Myrddin
Newbie
*
Posts: 16


View Profile Email
« Reply #3 on: July 05, 2006, 02:59:40 pm »

Okay, I tried reinstalling the win32libs again (same exe though) and it seems to be getting further, so I am crossing my fingers Smiley
Logged
kiper
Newbie
*
Posts: 17


View Profile Email
« Reply #4 on: July 05, 2006, 07:44:42 pm »

I have installed several times without any problem following this tutorial:

http://www.crystalspace3d.org/CelTutorial.pdf
Logged

1800MHz Intel Centrino
1GB RAM
128 ATI Mobility Radeon X700
Win XP Pro SP2
Myrddin
Newbie
*
Posts: 16


View Profile Email
« Reply #5 on: July 06, 2006, 01:12:07 am »

I have installed several times without any problem following this tutorial:

http://www.crystalspace3d.org/CelTutorial.pdf
Hey it works! I can run all the demos no problem!

Now another question - I created a Makefile in my Linux install of CS based on the examples. Make no longer works on the Windows project though, saying immediately "cannot find -ldl" and "ld returned 1 exit status".

Using cygwin, by the way. Is there an additional library in cygwin setup I need to add, or something in the Makefile I need to change?
Logged
Pages: [1] Print 
« previous next »
Jump to:  

Powered by MySQL Powered by PHP Powered by SMF 1.1.2 | SMF © 2006-2007, Simple Machines LLC Valid XHTML 1.0! Valid CSS!
Page created in 6.167 seconds with 16 queries.