Crystal Space
Welcome, Guest. Please login or register.
October 25, 2014, 11:25:13 pm

Login with username, password and session length
Search:     Advanced search
9011 Posts in 2044 Topics by 8828 Members
Latest Member: Saikjanna
* Home Help Search Login Register
+  Crystal Space
|-+  Crystal Space Development
| |-+  Game Content Creation
| | |-+  Anything needed for x64-bit/Vista support?
« previous next »
Pages: [1] Print
Author Topic: Anything needed for x64-bit/Vista support?  (Read 2870 times)
Panch
Jr. Member
**
Posts: 80


View Profile Email
« on: June 26, 2007, 05:18:40 pm »

Ok,

Initially when I had CS/my app running on 64-bit Vista it worked out great. But when I try to change a level and load a different one, like from my main menu level to the 1st level, it crashes in engine.cpp with something regarding if no default render loop i think. I haven't really debugged it just yet so I haven't narrowed it down enough to ask any specific questions; but are they any settings that I should use if I am running a 64-bit version of Windows/Vista.

*This all works fine in a XP 32-bit OS.

Thanks!
Logged
Panch
Jr. Member
**
Posts: 80


View Profile Email
« Reply #1 on: July 09, 2007, 03:40:15 am »

OK well it's a memory problem. The renderloop is not being destroyed properly by the appropriate calls (engine->DeleteAll(), or the Quit event), I know this is the case because if I restart my computer and clear the memory out the program works fine on the first load; but once that renderloop is loaded into memory it seems to stick. Oh well!
Logged
Pages: [1] Print 
« previous next »
Jump to:  

Powered by MySQL Powered by PHP Powered by SMF 1.1.2 | SMF © 2006-2007, Simple Machines LLC Valid XHTML 1.0! Valid CSS!
Page created in 3.796 seconds with 14 queries.