Crystal Space
Welcome, Guest. Please login or register.
November 21, 2017, 01:37:52 am

Login with username, password and session length
Search:     Advanced search
9081 Posts in 2051 Topics by 80546 Members
Latest Member: Zenzokueng743
* Home Help Search Login Register
+  Crystal Space
|-+  Crystal Space Development
| |-+  Support
| | |-+  celtst fails to run (cannot load shared object library)
« previous next »
Pages: [1] Print
Author Topic: celtst fails to run (cannot load shared object library)  (Read 3451 times)
Posts: 1

View Profile Email
« on: June 21, 2007, 12:09:20 am »

I'm currently running Ubuntu Linux 7.04 and I'm trying to get Crystal Space with CEL working.  I used sudo apt-get install to install many libraries required by Crystal Space (I got most of them because they were listed as prerequisites for compiling Open Outcast).  The only library I didn't get with sudo apt-get install was cal3d.  The one in Ubuntu's respitories was too old so I had to compile and install that myself.  I compiled both Crystal Space and CEL successfully (when the ./configure script was told to exclude Python) and installed them (sudo jam install).  All the programs which were created when I compiled Crystal Space run perfectly (including walktest).  However, none of the CEL programs I used worked.  They would show a window and then crash.  It didn't matter whether I ran them from the CEL directory or from their installation directory.  Error messages include:
DLERROR (/home/jack/CrystalSpace/CS_stable/ cannot open shared object file: No such file or directory
  could not load plugin 'crystalspace.mesh.loader.factory.sprite.cal3d'
However, exists in my /usr/local/lib directory.

The steps I took were:
Get cal3d, Crystal Space, CEL
Compile cal3d
Install cal3d
Compile Crystal Space
Install Crystal Space
Compile Cel.
Install Cel.
Run celtst.

I would really appreciate it if someone could help me solve this problem.
Posts: 48

View Profile
« Reply #1 on: June 21, 2007, 07:22:46 pm »

add '/usr/local/lib' entry to /etc/

ldconfig /usr/local/lib
Posts: 21

View Profile Email
« Reply #2 on: July 07, 2007, 07:54:23 pm »

i have the same problem
 could not load plugin 'crystalspace.window.x.extf86vm'

but my problem is still there
Pages: [1] Print 
« previous next »
Jump to:  

Powered by MySQL Powered by PHP Powered by SMF 1.1.2 | SMF © 2006-2007, Simple Machines LLC Valid XHTML 1.0! Valid CSS!
Page created in 6.227 seconds with 16 queries.