Crystal Space
Welcome, Guest. Please login or register.
October 01, 2014, 01:22:55 pm

Login with username, password and session length
Search:     Advanced search
9020 Posts in 2053 Topics by 8568 Members
Latest Member: Chajsay
* Home Help Search Login Register
+  Crystal Space
|-+  Crystal Space Development
| |-+  General Crystal Space Discussion
| | |-+  iMeshWrapper::HitBeam() has strange behaviour
« previous next »
Pages: [1] Print
Author Topic: iMeshWrapper::HitBeam() has strange behaviour  (Read 2714 times)
hermitC
Newbie
*
Posts: 7


View Profile
« on: August 08, 2007, 11:28:30 pm »

I'm using Blender2CS and CS 1.0. My engine (on top of CS) makes top down beam tests to determine the height of the environment at specific 2D points.

The first thing is that HitBeam() does not return the first intersection point but the closest to y=0. E.g. two planes one over the other -> lower plane (closer to y=0) will contain intersection point from top down beam starting above top plane and ending below lower plane. I have tested this with the inverse beam - the same result.

Second problem: The method seems to have problems with mesh edges. Sometimes there is no hit when the top down beam goes through an (not horizontal) edge.

Did I overlook something or is it a bug?

Cheers,
hermitC
Logged
hermitC
Newbie
*
Posts: 7


View Profile
« Reply #1 on: August 14, 2007, 03:33:50 pm »

Is really nobody out there who encountered a similar problem with HitBeam()?

Cheers,
hermitC
Logged
Darek
Newbie
*
Posts: 48



View Profile
« Reply #2 on: August 14, 2007, 08:37:58 pm »

Try to use lastest CS, not 1.0.
Logged
Pages: [1] Print 
« previous next »
Jump to:  

Powered by MySQL Powered by PHP Powered by SMF 1.1.2 | SMF © 2006-2007, Simple Machines LLC Valid XHTML 1.0! Valid CSS!
Page created in 4.163 seconds with 16 queries.