Crystal Space
Welcome, Guest. Please login or register.
November 27, 2014, 06:35:30 am

Login with username, password and session length
Search:     Advanced search
9026 Posts in 2046 Topics by 9141 Members
Latest Member: Corneliussummers
* Home Help Search Login Register
+  Crystal Space
|-+  Crystal Space Development
| |-+  Support
| | |-+  [Q] CELstart 1.2 (Linux) install error - Wrong Python version
« previous next »
Pages: [1] Print
Author Topic: [Q] CELstart 1.2 (Linux) install error - Wrong Python version  (Read 4121 times)
Kriss
Newbie
*
Posts: 49



View Profile
« on: June 12, 2008, 12:01:37 pm »

Greetings!
Today I tried to install CELstart on Linux (my version is very similar to Slackware 12.1), but after downloading and installing all necessary packages I got this error in installer(translation, maybe not 100% correct):
ERROR: 'Python language runtime' package was found, but version is wrong, necessary version wasn't found.
[IV 2.4 for @python.org/python]
ERROR: An error happened while checking package CELstart
Is there any way to avoid this without downgrading (I think...) Python 2.5.x to 2.4.x?
« Last Edit: June 12, 2008, 12:09:36 pm by Kriss » Logged
Vincent
Full Member
***
Posts: 191


View Profile WWW
« Reply #1 on: June 12, 2008, 05:18:29 pm »

Hello,

  please try one of the more recent CELStart 1.2.1 binaries, they were built against python 2.5
http://www.crystalspace3d.org/downloads/contrib/celstart-1.2.1-linux-x86.tar.bz2
http://www.crystalspace3d.org/downloads/contrib/celstart-1.2.1-linux-x86_64.tar.bz2
(use the former if your system is 32bits, the latter if 64bits).
Note that you may have to add the resulting celstart directory to your LD_LIBRARY_PATH environment variable for python support to work.

Downgrading system-wide installed python to 2.4 would be risky to say the least (don't do it !).
However, building it yourself from source and putting it in a non-system directory and using it only as needed should do no harm.
Hopefuly, that won't be needed with these more recent builds.
Logged
Kriss
Newbie
*
Posts: 49



View Profile
« Reply #2 on: June 12, 2008, 05:35:32 pm »

Thank you!
BTW how did you find them? o.O
Logged
Vincent
Full Member
***
Posts: 191


View Profile WWW
« Reply #3 on: June 12, 2008, 05:55:23 pm »

Thank you!
BTW how did you find them? o.O
Because I made them, and asked to have them available for download on CS website grin
Thanks for reminding me to update the CELStart download page, I'll do that now...
Logged
Kriss
Newbie
*
Posts: 49



View Profile
« Reply #4 on: June 12, 2008, 06:16:40 pm »

That explains much... Smiley
BTW
Quote
Note that you may have to add the resulting celstart directory to your LD_LIBRARY_PATH environment variable for python support to work.
You meant to create a file like this?
Code:
#!/bin/sh
cd /path/to/crystalspace/
env "LD_LIBRARY_PATH=./" ./celstart_static
« Last Edit: June 12, 2008, 06:22:40 pm by Kriss » Logged
Vincent
Full Member
***
Posts: 191


View Profile WWW
« Reply #5 on: June 12, 2008, 06:40:03 pm »

Code:
#!/bin/sh
cd /path/to/crystalspace/
env "LD_LIBRARY_PATH=./" ./celstart_static

Yes, that should work.
Logged
Kriss
Newbie
*
Posts: 49



View Profile
« Reply #6 on: June 15, 2008, 08:34:21 am »

P.S.
Windows version (http://www.crystalspace3d.org/downloads/contrib/celstart-1.2.1-windows.zip)
requires python25.dll and I didn't find it in the archive...
Logged
Vincent
Full Member
***
Posts: 191


View Profile WWW
« Reply #7 on: June 15, 2008, 10:11:27 pm »

Windows version (http://www.crystalspace3d.org/downloads/contrib/celstart-1.2.1-windows.zip)
requires python25.dll and I didn't find it in the archive...

Yes, you need to install python 2.5, and possibly add Python install directory (where python25.dll resides) to the PATH.
Logged
Kriss
Newbie
*
Posts: 49



View Profile
« Reply #8 on: June 16, 2008, 01:02:08 am »

Well, yes... I noted this because it needs this file to actually run CELstart 1.2.1 (and doesn't have it out-of-the-box while CELstart 1.2 does have python24.dll included and doesn't require anything).
P.S.
Didn't understand why walktest was there...
I didn't have this dll after installing python 2.5.2... I got it from blender and copied to CELstart directory...
After that everything was fine... Thanks for update.
Hope you don't mind me nitpicking... Smiley
« Last Edit: June 16, 2008, 01:07:19 am by Kriss » Logged
Pages: [1] Print 
« previous next »
Jump to:  

Powered by MySQL Powered by PHP Powered by SMF 1.1.2 | SMF © 2006-2007, Simple Machines LLC Valid XHTML 1.0! Valid CSS!
Page created in 7.43 seconds with 16 queries.