Crystal Space
Welcome, Guest. Please login or register.
July 30, 2014, 08:34:58 pm

Login with username, password and session length
Search:     Advanced search
9005 Posts in 2043 Topics by 8260 Members
Latest Member: Lovelymae39
* Home Help Search Login Register
+  Crystal Space
|-+  Crystal Space Development
| |-+  Support
| | |-+  DLL file missing :(
« previous next »
Pages: [1] Print
Author Topic: DLL file missing :(  (Read 4799 times)
Core
Newbie
*
Posts: 1


View Profile Email
« on: October 15, 2008, 06:58:46 pm »

Hello,
Im new too the CS forum so first of all HI everyone!! Smiley

I've been compiling Crystal Space for a couple of weeks now but most of the time it ends up with the same problem
By compiling CS with the guide provided by CS itself I can't get it too work,
When I start one of the several demo programs it tells me:  crystalspace-1.4-vc8.dll can't be found.
After all I did only see 1 single error during compiling which would have been this DLL I think.

Can someone please help me with this? or provide the dll I'm missing?

SPECS:
Normal: WIndows XP X64 bit Prof SP2

On compile machine: Windows XP 32bit Prof SP2

Intel Core 2 Extreme QX9650 @ 3.6Ghz
Asus Striker II Extreme MOBO
Kingston DDRIII 8GB (1600 MHZ)
3x nVidia Geforce 9800GX2
2x 1TB Western Digital HDD
CS revision: 31423
WIN32LIBS: cs-win32libs-1.3_004


Thanks in Advance.
« Last Edit: October 15, 2008, 07:03:30 pm by Core » Logged
Vincent
Full Member
***
Posts: 191


View Profile WWW
« Reply #1 on: October 20, 2008, 06:54:45 pm »

Hello,

  You should check what the build error exactly is, and report it here.
Logged
Franimus
Newbie
*
Posts: 2


View Profile Email
« Reply #2 on: October 01, 2013, 09:56:09 pm »

I think I'm having the same problem.  When I try to run an app, I get the message (without _d when I try it in release mode):
Quote
The program can't start because crystalspace-2.0-vc10_d.dll is missing from your computer.  Try reinstalling the program to fix this problem.

Is there something I haven't set up correctly?  I'm using VS 2010 on Windows 7.  Here is what I have done:
System Environment variables:
CRYSTAL = c:\crystalspace-src-2.0
CEL = c:\cel-src-2.0

Linker - Additional library directories:
C:\cel-src-2.0;c:\crystalspace-src-2.0

VC++ Directories:
Include: c:\cel-src-2.0\include;c:\crystalspace-src-2.0\include
Library: c:\cel-src-2.0\out\debug10\libs;c:\crystalspace-src-2.0\out\debug10\libs

I also get these messages in the output when I try to run it:
Quote
'test.exe': Loaded 'C:\Users\Francis\Documents\Visual Studio 2010\Projects\test\Debug\test.exe', Symbols loaded.
'test.exe': Loaded 'C:\Windows\SysWOW64\ntdll.dll', Cannot find or open the PDB file
'test.exe': Loaded 'C:\Windows\SysWOW64\kernel32.dll', Cannot find or open the PDB file
'test.exe': Loaded 'C:\Windows\SysWOW64\KernelBase.dll', Cannot find or open the PDB file
The program '[6024] test.exe: Native' has exited with code -1073741515 (0xc0000135).
« Last Edit: October 01, 2013, 10:02:53 pm by Franimus » Logged
Pages: [1] Print 
« previous next »
Jump to:  

Powered by MySQL Powered by PHP Powered by SMF 1.1.2 | SMF © 2006-2007, Simple Machines LLC Valid XHTML 1.0! Valid CSS!
Page created in 5.278 seconds with 14 queries.