Crystal Space
Welcome, Guest. Please login or register.
July 24, 2014, 04:39:23 pm

Login with username, password and session length
Search:     Advanced search
9005 Posts in 2043 Topics by 8228 Members
Latest Member: Leandes
* Home Help Search Login Register
+  Crystal Space
|-+  Crystal Space Development
| |-+  Support
| | |-+  simple1 weird error
« previous next »
Pages: [1] Print
Author Topic: simple1 weird error  (Read 2963 times)
Zuero
Newbie
*
Posts: 19


View Profile Email
« on: December 23, 2008, 03:51:53 am »

I am trying to follow the tutorial from the Basics and Overview section of the CS manual to compile the simple1 application from a new project.

After setting all the correct settings in the tutorial, I still can't compile it because of this weird error that I can't seem to solve.

1>c1xx : fatal error C1083: Cannot open source file: 'Files\CS\crystalspace-src-1.2.1\apps\tutorial\simple1\simple1.cpp': No such file or directory

Thing iss. That simple1.cpp file IS located where it says in the error. I tried setting it as a dependency but no luck.

Can someone tell me what is wrong here, and help me to fix it?
Logged
jorrit
Administrator
Hero Member
*****
Posts: 1706


View Profile
« Reply #1 on: December 23, 2008, 06:13:20 am »

Your path looks a bit weird: 'Files\CS\...'? It doesn't start with a drive letter so it is a relative path. I think you want to start with a drive letter.

Greetings,
Logged
Zuero
Newbie
*
Posts: 19


View Profile Email
« Reply #2 on: December 23, 2008, 11:24:36 am »

How do I change the path. I checked the dependencies and everything is fine. There is no path that says 'Files\CS\crystalspace-src-1.2.1\apps\tutorial\simple\simple1.cpp'
« Last Edit: December 23, 2008, 11:26:11 am by Zuero » Logged
jorrit
Administrator
Hero Member
*****
Posts: 1706


View Profile
« Reply #3 on: December 23, 2008, 11:27:25 am »

Well I assume you're using MSVC? If so then how did you set the path when you created the project?

Greetings,
Logged
Zuero
Newbie
*
Posts: 19


View Profile Email
« Reply #4 on: December 23, 2008, 12:28:12 pm »

Well when i created it, I just followed the exact instructions in the Basics and Overview Tutorial, and before that, the exact instructions on compiling Crystal Space. So basically the paths I set, in the dependencies, are the include, and lib, and the bin paths for CS.
Logged
jorrit
Administrator
Hero Member
*****
Posts: 1706


View Profile
« Reply #5 on: December 23, 2008, 12:48:30 pm »

Ok, then double check all the paths you set there.

Greetings,
Logged
Zuero
Newbie
*
Posts: 19


View Profile Email
« Reply #6 on: December 23, 2008, 11:57:37 pm »

The paths are perfectly fine.
Logged
Vincent
Full Member
***
Posts: 191


View Profile WWW
« Reply #7 on: January 12, 2009, 06:57:14 pm »

I guess there's a space character in CS path which is not correctly handled...
Try moving CS somewhere like C:\dev\CS (any path without space in it).
Logged
Pages: [1] Print 
« previous next »
Jump to:  

Powered by MySQL Powered by PHP Powered by SMF 1.1.2 | SMF © 2006-2007, Simple Machines LLC Valid XHTML 1.0! Valid CSS!
Page created in 5.141 seconds with 16 queries.