Crystal Space
Welcome, Guest. Please login or register.
July 12, 2014, 02:07:42 am

Login with username, password and session length
Search:     Advanced search
9005 Posts in 2043 Topics by 8147 Members
Latest Member: Quintwinn
* Home Help Search Login Register
+  Crystal Space
|-+  Crystal Space Development
| |-+  Support
| | |-+  Blender plugin linux
« previous next »
Pages: [1] Print
Author Topic: Blender plugin linux  (Read 4640 times)
thefiestysoldier
Newbie
*
Posts: 1


View Profile Email
« on: January 19, 2009, 09:50:00 pm »

The blender to crystal exporter doesnt work on my ubuntu intrepid system, will it ever be updated? Any workarounds? I am even up to using another modeling program, any suggestions?
Logged
jorrit
Administrator
Hero Member
*****
Posts: 1706


View Profile
« Reply #1 on: January 20, 2009, 06:11:32 am »

Why do you think it doesn't work? People have been using it on ubuntu. Perhaps tell us what the problem is so that we can help you solve it.

Greetings,
Logged
Weaponx69
Newbie
*
Posts: 5


View Profile Email
« Reply #2 on: August 31, 2009, 01:58:14 pm »

I'm having trouble with my blender2crystal exporter tool also.  I am using ubuntu jaunty with blender 2.49.  I'm just trying to get the exporter to work for the first time.  I keep getting a console error that I saw on another post from a windows user.  I installed it from packages.  I copied all the files to home/myaccount/.blender/scripts/ but that doesnt work.  I also exported the CRYSTAL variable and that doesn't work either.  It was unusually hard to even find the packages.  I tried to install the files into scripts directly also and it doesn't work.  Sorry, I don't have a console right now to show you.  I will post it later.  I just wanted to make sure someone was out there.
Logged
Weaponx69
Newbie
*
Posts: 5


View Profile Email
« Reply #3 on: August 31, 2009, 04:10:55 pm »

Hi,
   I posted the link above.  Here is the output I get from the moment I call blender from the command line until I try to use the crystal export.

weaponx69@weaponx69-desktop:/usr/share/crystalspace-1.4$ blender
Compiled with Python version 2.6.2.
Checking for installed Python... got it!
/home/weaponx69/.blender/scripts/bpymodules/b2cs/util/run.py:5: DeprecationWarning: The popen2 module is deprecated.  Use the subprocess module.
  import popen2
Traceback (most recent call last):
  File "<string>", line 1, in <module>
  File "/home/weaponx69/.blender/scripts/blender/crystalspace_export.py", line 46, in <module>
    import b2cs
  File "/home/weaponx69/.blender/scripts/bpymodules/b2cs/__init__.py", line 49, in <module>
    import defaults
  File "/home/weaponx69/.blender/scripts/bpymodules/b2cs/defaults.py", line 5, in <module>
    import b2cs.metadata
  File "/home/weaponx69/.blender/scripts/bpymodules/b2cs/metadata.py", line 475, in <module>
    b2cs.prop.wid_keys = UiProperties()
  File "/home/weaponx69/.blender/scripts/bpymodules/b2cs/metadata.py", line 444, in __init__
    self.Refresh()
  File "/home/weaponx69/.blender/scripts/bpymodules/b2cs/metadata.py", line 447, in Refresh
    self.loadFromMetadata()
  File "/home/weaponx69/.blender/scripts/bpymodules/b2cs/metadata.py", line 450, in loadFromMetadata
    for wid in world_metadata.getNodes():
  File "/home/weaponx69/.blender/scripts/bpymodules/b2cs/metadata.py", line 234, in getNodes
    sect = self.getSection()
  File "/home/weaponx69/.blender/scripts/bpymodules/b2cs/metadata.py", line 228, in getSection
    root = self.getRoot()
  File "/home/weaponx69/.blender/scripts/bpymodules/b2cs/metadata.py", line 206, in getRoot
    propval = xpath(self.internalroot,"//prop[@name='metadata_file']/@value")
  File "/home/weaponx69/.blender/scripts/bpymodules/b2cs/xmlutils.py", line 47, in xml_xpath
    nodes = node.xpath(xpath)
AttributeError: Element instance has no attribute 'xpath'

Logged
zamme
Newbie
*
Posts: 16


View Profile Email
« Reply #4 on: August 31, 2009, 04:17:15 pm »

The ubuntu packages from the repositories are too much old. The best way to install it is from source, the lasts svn trunk and 1.4 works perfectly for me on ubuntu.

1.4:
https://crystal.svn.sourceforge.net/svnroot/crystal/CS/branches/release/V1.4
https://cel.svn.sourceforge.net/svnroot/cel/cel/branches/release/V1.4

trunk:
https://crystal.svn.sourceforge.net/svnroot/crystal/CS/trunk
https://cel.svn.sourceforge.net/svnroot/cel/cel/trunk

B2CS:
https://b2cs.delcorp.org/svn/blender2crystal/branches/release_0_7_0

And remember to declare the variables before launch blender:
CRYSTAL=/CrystalPath/
CEL=/CELPath/
LD_LIBRARY_PATH=$CRYSTAL;$CEL

If you want a script I found one in the internet to download and compile all automatically.

See you...
Logged
Weaponx69
Newbie
*
Posts: 5


View Profile Email
« Reply #5 on: August 31, 2009, 04:43:31 pm »

Hi,
   Thanks for the fast reply.  I posted a new post because I didn't see a response.  My other post is more detailed and maybe you will be able to find the problem so I can avoid reinstalling something else.  If you don't see anything, I would really like to see that script to install everything automatically.  That would be the best!   

Thanks.
Logged
zamme
Newbie
*
Posts: 16


View Profile Email
« Reply #6 on: September 01, 2009, 04:09:08 pm »

Hi,
   You can download it from the Svmres project:

               http://www.svmres.org/arxius/CrystalPack.sh

See you...
Logged
booner
Newbie
*
Posts: 1


View Profile Email
« Reply #7 on: January 21, 2011, 11:46:16 pm »

Hi,
   I posted the link above.  Here is the output I get from the moment I call blender from the command line until I try to use the crystal export.

weaponx69@weaponx69-desktop:/usr/share/crystalspace-1.4$ blender
Compiled with Python version 2.6.2.
Checking for installed Python... got it!
/home/weaponx69/.blender/scripts/bpymodules/b2cs/util/run.py:5: DeprecationWarning: The popen2 module is deprecated.  Use the subprocess module.
  import popen2
Traceback (most recent call last):
  File "<string>", line 1, in <module>
  File "/home/weaponx69/.blender/scripts/blender/crystalspace_export.py", line 46, in <module>
    import b2cs
  File "/home/weaponx69/.blender/scripts/bpymodules/b2cs/__init__.py", line 49, in <module>
    import defaults
  File "/home/weaponx69/.blender/scripts/bpymodules/b2cs/defaults.py", line 5, in <module>
    import b2cs.metadata
  File "/home/weaponx69/.blender/scripts/bpymodules/b2cs/metadata.py", line 475, in <module>
    b2cs.prop.wid_keys = UiProperties()
  File "/home/weaponx69/.blender/scripts/bpymodules/b2cs/metadata.py", line 444, in __init__
    self.Refresh()
  File "/home/weaponx69/.blender/scripts/bpymodules/b2cs/metadata.py", line 447, in Refresh
    self.loadFromMetadata()
  File "/home/weaponx69/.blender/scripts/bpymodules/b2cs/metadata.py", line 450, in loadFromMetadata
    for wid in world_metadata.getNodes():
  File "/home/weaponx69/.blender/scripts/bpymodules/b2cs/metadata.py", line 234, in getNodes
    sect = self.getSection()
  File "/home/weaponx69/.blender/scripts/bpymodules/b2cs/metadata.py", line 228, in getSection
    root = self.getRoot()
  File "/home/weaponx69/.blender/scripts/bpymodules/b2cs/metadata.py", line 206, in getRoot
    propval = xpath(self.internalroot,"//prop[@name='metadata_file']/@value")
  File "/home/weaponx69/.blender/scripts/bpymodules/b2cs/xmlutils.py", line 47, in xml_xpath
    nodes = node.xpath(xpath)
AttributeError: Element instance has no attribute 'xpath'



This exact error was happening to me as well under Fedora 13. It was finally fixed when setting up the PYTHONPATH environment variable with the command:

export PYTHONPATH=/usr/share/blender/scripts/bpymodules;

- Booner
Logged
Pages: [1] Print 
« previous next »
Jump to:  

Powered by MySQL Powered by PHP Powered by SMF 1.1.2 | SMF © 2006-2007, Simple Machines LLC Valid XHTML 1.0! Valid CSS!
Page created in 9.307 seconds with 17 queries.