Crystal Space
Welcome, Guest. Please login or register.
April 25, 2014, 07:25:33 am

Login with username, password and session length
Search:     Advanced search
8990 Posts in 2037 Topics by 7631 Members
Latest Member: Nancyczajk
* Home Help Search Login Register
+  Crystal Space
|-+  Associate Projects
| |-+  CEL Discussion
| | |-+  checking if CEL SDK is usable... no
« previous next »
Pages: [1] Print
Author Topic: checking if CEL SDK is usable... no  (Read 3266 times)
Ardvark
Newbie
*
Posts: 1


View Profile Email
« on: February 07, 2009, 09:44:26 pm »

NO, what do you mean no!

Hi, (first post)

I'm running linux (FC10) and took the easy option and used yum to install crystalspace. Over the past couple of days i've read most of the documentation and compiled the examples and tutorials that i've found.

Tonight I decided to move on and do some research. When looking into 3rd person cameras and the such it became apparent that using CEL is the way to go. So i've read a fair bit of cel's doc's and dived into the tutorial.

After realising that I had to say yes to the last question on the 'createproject.sh' (too obvious!), I then got the following error whilst running './configure'.

Code:
...
checking for cs-config-1.1... no
checking for cs-config-1.2... /usr/bin/cs-config-1.2
checking if Crystal Space version >= 1.1... yes (version 1.2.1)
checking if Crystal Space SDK is usable... yes
checking for cel-config-1.... no
checking for cel-config-1.2... /usr/bin/cel-config-1.2
checking if CEL version >= 1.1... yes (version 1.2)
checking if CEL SDK is usable... no
configure: error:
*** CEL could not be found or was unusable. The latest version is always
*** available from http://cel.crystalspace3d.org/

Knowing i'd read something about environment variables somewhere I did a quick search here and tried the following two sets:

Code:
export CRYSTAL=/usr/lib/crystalspace-1.2
export CEL=/usr/lib/cel-1.2
export PATH=$PATH:$CRYSTAL:$CEL
and
Code:
export CRYSTAL=/etc/crystalspace-1.2
export CEL=/etc/cel-1.2
export PATH=$PATH:$CRYSTAL:$CEL
and
Code:
export CRYSTAL=/usr/share/crystalspace-1.2
export CEL=/usr/share/cel-1.2/
export PATH=$PATH:$CRYSTAL:$CEL
(obviously amending path between attempts)

However i'm still experiencing the same as before, so I you once again...
NO, what do you mean no!

Yep, there's probably a very simple answer for this, so cheers!

P.S.
I've also had a play with setting LD_LIBRARY_PATH to all the cs paths above...
« Last Edit: February 07, 2009, 10:44:05 pm by Ardvark » Logged
Vincent
Full Member
***
Posts: 191


View Profile WWW
« Reply #1 on: May 18, 2009, 08:17:34 pm »

When CS is installed, there should be no need to set CRYSTAL environment variable.
For CEL, I'm not sure, it's been quite a while since I tried.
It would be interesting to check the config.log file, and see the exact reason why the usability check failed...
Logged
Pages: [1] Print 
« previous next »
Jump to:  

Powered by MySQL Powered by PHP Powered by SMF 1.1.2 | SMF © 2006-2007, Simple Machines LLC Valid XHTML 1.0! Valid CSS!
Page created in 5.403 seconds with 16 queries.