Crystal Space
Welcome, Guest. Please login or register.
April 25, 2014, 02:28:30 am

Login with username, password and session length
Search:     Advanced search
8990 Posts in 2037 Topics by 7629 Members
Latest Member: Mariabrown
* Home Help Search Login Register
+  Crystal Space
|-+  Crystal Space Development
| |-+  Support
| | |-+  setting up the two renderers
« previous next »
Pages: [1] Print
Author Topic: setting up the two renderers  (Read 2401 times)
Sl0w
Guest


Email
« on: July 08, 2005, 10:26:39 pm »

Hello, I have 2 questions:

1. How do I properly configure/make the software renderer?
So far I've managed to compile CS but the test examples yield:

./simple1 -video=software
NOTIFY: Using alternative 3D driver: crystalspace.graphics3d.software
DLERROR (/home/gothic/CS/x2d.csplugin): /home/gothic/CS/x2d.so: cannot open shared object file: No such file or directory
Segmentation fault

And yes, the x2d plugin didn't compile(I've set the CS var).

2. How do I properly configure/make the opengl renderer?

I've tried instructing the 'configure' to look for opengl headers with: --includedir:/(here lay the path to includes) and it didn't work.
Logged
jorrit
Administrator
Hero Member
*****
Posts: 1704


View Profile
« Reply #1 on: July 09, 2005, 06:20:45 am »

Hello, I have 2 questions:

1. How do I properly configure/make the software renderer?
So far I've managed to compile CS but the test examples yield:

./simple1 -video=software
NOTIFY: Using alternative 3D driver: crystalspace.graphics3d.software
DLERROR (/home/gothic/CS/x2d.csplugin): /home/gothic/CS/x2d.so: cannot open shared object file: No such file or directory
Segmentation fault

And yes, the x2d plugin didn't compile(I've set the CS var).

2. How do I properly configure/make the opengl renderer?

I've tried instructing the 'configure' to look for opengl headers with: --includedir:/(here lay the path to includes) and it didn't work.

What happens if you type 'jam x2d'?

Greetings,
Logged
Sl0w
Guest


Email
« Reply #2 on: July 09, 2005, 09:03:25 am »

Looks like I was missing some X headers. Thanks, fixed the software one:)
Logged
Sl0w
Guest


Email
« Reply #3 on: July 10, 2005, 08:21:39 pm »

do you know what config options I need to specify to use the opengl renderer huh
Logged
dingobloo
Idle Extrordinare.
Global Moderator
Full Member
*****
Posts: 125


View Profile WWW
« Reply #4 on: July 11, 2005, 12:04:08 pm »

The Software and OpenGL renderer should be compiled together as long as everything has compiled correctly.
Logged
Sl0w
Guest


Email
« Reply #5 on: July 11, 2005, 03:17:42 pm »

Success:) installed the ati driver with some difficulty and it worked, thanks for your help
Logged
Pages: [1] Print 
« previous next »
Jump to:  

Powered by MySQL Powered by PHP Powered by SMF 1.1.2 | SMF © 2006-2007, Simple Machines LLC Valid XHTML 1.0! Valid CSS!
Page created in 3.185 seconds with 16 queries.