Crystal Space
Welcome, Guest. Please login or register.
December 20, 2014, 05:33:19 am

Login with username, password and session length
Search:     Advanced search
9032 Posts in 2046 Topics by 9293 Members
Latest Member: Michaelcrist
* Home Help Search Login Register
+  Crystal Space
|-+  Crystal Space Development
| |-+  Support
| | |-+  Strange Linux install problem
« previous next »
Pages: [1] Print
Author Topic: Strange Linux install problem  (Read 1733 times)
Weedfreak
Newbie
*
Posts: 2


View Profile Email
« on: June 13, 2009, 08:29:28 am »

I have been meaning to get back to developing for some time and now that I have a box that is at least stable I have started adding dev tools like CS to it.

Initially I tried 1,2 as it is listed as latest stable version, I got lots of depreciated messages when building and walktest had all sorts of problems mainly with shaders. I made an assumption that I may have too new a system for a fairly old version of CS, I am running Xubuntu jaunty on an AMD phenon system with Nvidia 9800GX2 and tried the latest snapshot version, seems like it is 1.9.

Configure seems to run OK, jam runs Ok though I do get a message that 1 target failed, jam install also seems to work ok, at least it creates and populates /usr/local/share/crystalspace-1.9. At this point I can run walktest and it seems to be as it should but if I then run jam distclean then walktest, and every other installed demo does not work, file not found error.

Obviously I am doing something wrong but I would appreciate someone pointing out my error.
Logged
Vincent
Full Member
***
Posts: 191


View Profile WWW
« Reply #1 on: June 15, 2009, 10:00:44 pm »

Hello !

  don't bother installing CS, especially if you're a programmer.
Since there's no uninstall program/target, it can be tricky at times, when you're dealing with multiple builds.
Install is really only useful for packagers...

For the failed target, it would help if you actually told us what fails exactly.

For the deprecated warnings, they just help people keeping their app up-to-date with next CS version,
encouraging them to use the "new way" of doing things (ie. use this method instead of that one).
Generally, there are instruction in the manual's release notes appendix about how to do this.
Logged
Weedfreak
Newbie
*
Posts: 2


View Profile Email
« Reply #2 on: June 28, 2009, 07:23:52 am »

Having investigated further I have decided that CS is probably not the app I need, but I may come back to it later.

As for the target failed error, all I got as a message was " (several thousand) targets built, 1 target failed " no other hint to what or why.

The depreciated warnings were only when building CS 1.2.

For once I read the readme file and followed the instructions and that seems to be my error.
Logged
Pages: [1] Print 
« previous next »
Jump to:  

Powered by MySQL Powered by PHP Powered by SMF 1.1.2 | SMF © 2006-2007, Simple Machines LLC Valid XHTML 1.0! Valid CSS!
Page created in 7.183 seconds with 16 queries.