Crystal Space
Welcome, Guest. Please login or register.
July 28, 2014, 07:51:22 am

Login with username, password and session length
Search:     Advanced search
9005 Posts in 2043 Topics by 8244 Members
Latest Member: Gregoryjerson
* Home Help Search Login Register
+  Crystal Space
|-+  Associate Projects
| |-+  CEL Discussion
| | |-+  celstart undefined symbol
« previous next »
Pages: [1] Print
Author Topic: celstart undefined symbol  (Read 2179 times)
Joepadmiraal
Newbie
*
Posts: 5


View Profile WWW Email
« on: September 12, 2009, 07:25:42 pm »

I run CS  r32906 and CEL r3997 with the most recent b2cs version on OpenSUSE11.1
When I try to load a world.zip generated by b2cs with celstart, I get the following error:
Code:
Traceback (most recent call last): 
  File "<string>", line 1, in <module>
  File "/usr/local/share/cel-1.4/bindings/python/blcelc.py", line 6, in <module>
    import _blcelc                                                             
ImportError: /usr/local/share/cel-1.4/bindings/python/_blcelc.so: undefined symbol: _ZN23SwigDirector_pyPcCommon11SetPropertyEml                                                                                                       
Error running text 'import blcelc'                                                                                 

crystalspace.pluginmgr.loadplugin:
  failed to initialize plugin 'cel.behaviourlayer.python'
Warning: too many resources                                                                                         
Segmentatiefout   

I do have the _blcelc.so file and it is generated from the clean build I did today.
I don't understand how _blcelc.so is generated so I don't know how to investigate this problem.
Can anyone give me some pointers, or maybe even a solution?

Thanks in advance,
Joep Admiraal
Logged
Joepadmiraal
Newbie
*
Posts: 5


View Profile WWW Email
« Reply #1 on: September 24, 2009, 04:46:31 pm »

Pablo Martin gave me the answer to this one:
Quote
Hi!

The problem seems to be in compiling cel and cs without swig (its a tool
you have to install, and then configure cel and cs again). It should be
ok, but also there seems to be some old file in the repo so you have to
generate your own (by having swig available at configure and compile time).

Any cs and cel versions should be ok, but the most tested ones are 1.4.

Greetings

 Pablo
Logged
Pages: [1] Print 
« previous next »
Jump to:  

Powered by MySQL Powered by PHP Powered by SMF 1.1.2 | SMF © 2006-2007, Simple Machines LLC Valid XHTML 1.0! Valid CSS!
Page created in 4.163 seconds with 16 queries.