Crystal Space
Welcome, Guest. Please login or register.
September 30, 2014, 02:50:42 pm

Login with username, password and session length
Search:     Advanced search
9020 Posts in 2053 Topics by 8556 Members
Latest Member: Boshyeng
* Home Help Search Login Register
+  Crystal Space
|-+  Associate Projects
| |-+  CEL Discussion
| | |-+  Running CEL in visual C++
« previous next »
Pages: [1] Print
Author Topic: Running CEL in visual C++  (Read 1750 times)
Jsrduck
Newbie
*
Posts: 4


View Profile Email
« on: April 07, 2010, 09:55:40 pm »

Hello,

CrystalSpace and CEL both successfully compiled for me, but when I try to run appcelstart, I get the error:
"The program can't start because crystalspace-1.4-vc9_d.dl is missing..."

I followed the instructions and added the directory which contains this dll (for me, C:\crystalspace-src-1.4.0\out\debug9\bin) to the VC++ directories  list through Tools->Options->Projects and Solutions->VC++ Directories. Yet it still can't find the dll.

Additionally, I noticed while looking at the properties that appceltst lists ..\..\..\CS\out\debug9\libs under "Additional Library Directories." This seems to assume that 1. My CrystalSpace directory is named CS (it's not) and 2. that the root CrystalSpace directory is in the same directory as CEL. I tried replacing ..\..\..\CS with $(CRYSTAL) but it didn't make any difference.

Thanks for your help,

Jordan
Logged
Crystalfur
Newbie
*
Posts: 30


View Profile Email
« Reply #1 on: April 15, 2010, 05:40:26 am »

I'll give it a shot.

Given that you're on Windows (b/c you're using msvc++),
your environmental variables should look like this:

Crystal Space:
Name: Crystal
Value: C:\CS (or C:\...whatever)

CEL:
Name: CEL
Value: C:\CEL (or C:\...whater)

In VC,
Tools-->Options-->Project and Solutions-->VC++ Directories:
Under Include:
C:\CS
C:\CEL
Under Library:
C:\CS\out\release9\libs
C:\CS\out\debug9\libs
C:\CEL\out\release9\libs
C:\...

Note that the directory where you have CS installed is not necessarily that but wherever you have it located. Same is true for CEL.
Make sure to include the appropriate Preprocessor definitions and the appropriate Additional Dependancies
Logged
Franimus
Newbie
*
Posts: 2


View Profile Email
« Reply #2 on: October 01, 2013, 10:34:58 pm »

I'll give it a shot.

Given that you're on Windows (b/c you're using msvc++),
your environmental variables should look like this:

Crystal Space:
Name: Crystal
Value: C:\CS (or C:\...whatever)

CEL:
Name: CEL
Value: C:\CEL (or C:\...whater)

In VC,
Tools-->Options-->Project and Solutions-->VC++ Directories:
Under Include:
C:\CS
C:\CEL
Under Library:
C:\CS\out\release9\libs
C:\CS\out\debug9\libs
C:\CEL\out\release9\libs
C:\...

Note that the directory where you have CS installed is not necessarily that but wherever you have it located. Same is true for CEL.
Make sure to include the appropriate Preprocessor definitions and the appropriate Additional Dependancies


I did this but I am still having the same problem whenever I try to run the application.  It compiles just fine.  I tried setting CRYSTAL and CEL both as system and user variables:
CRYSTAL
C:\crystalspace-src-2.0
CEL
C:\cel-src-2.0

I checked the file system and the .dll file is there in the root CS directory and the \out\release\bin directory.
Logged
Pages: [1] Print 
« previous next »
Jump to:  

Powered by MySQL Powered by PHP Powered by SMF 1.1.2 | SMF © 2006-2007, Simple Machines LLC Valid XHTML 1.0! Valid CSS!
Page created in 7.179 seconds with 16 queries.