Crystal Space
Welcome, Guest. Please login or register.
November 28, 2014, 12:34:04 pm

Login with username, password and session length
Search:     Advanced search
9026 Posts in 2046 Topics by 9154 Members
Latest Member: Salizpec
* Home Help Search Login Register
+  Crystal Space
|-+  Crystal Space Development
| |-+  Support
| | |-+  Python 2.6 support
« previous next »
Pages: [1] Print
Author Topic: Python 2.6 support  (Read 1506 times)
Squirrel-the-tire
Newbie
*
Posts: 7


View Profile Email
« on: February 02, 2011, 12:40:35 am »

Does anyone know why Crystal Space, CEL, CELstart, etc. won't work with python 2.6?
It's pretty impossible to run the newest of about any distro, and have python 2.5 installed. Is there really that much difference between the language versions? I thought they were compatible!
Logged
Squirrel-the-tire
Newbie
*
Posts: 7


View Profile Email
« Reply #1 on: February 02, 2011, 12:41:44 am »

Also, blender 2.49b uses python 2.6!
Logged
Squirrel-the-tire
Newbie
*
Posts: 7


View Profile Email
« Reply #2 on: February 02, 2011, 11:44:48 pm »

I guess the problem is that the stable release is so outdated. Building latest from svn now, hopefully it'll work so I can try this thing out. undecided
Logged
Squirrel-the-tire
Newbie
*
Posts: 7


View Profile Email
« Reply #3 on: February 05, 2011, 06:48:32 pm »

So from what I gather, the latest version of blender you can use with blender2crystal is 2.44? sounds like the script needs some major updating. It would be REALLY nice if we could use python3 and blender 2.56a, but at least blender 2.49b would be a good thing.
Logged
Squirrel-the-tire
Newbie
*
Posts: 7


View Profile Email
« Reply #4 on: February 05, 2011, 07:04:15 pm »

Where can I even get a binary for python 2.5?? Do I have to build that from source too??
Logged
kickvb
Global Moderator
Jr. Member
*****
Posts: 79


View Profile
« Reply #5 on: February 05, 2011, 08:17:23 pm »

For blender2crystal, you can use Blender up to 2.49, but limited to Python 2.5. See the following page for the installation process:
http://leapingcat.org/blender2crystal/index.php/ArtistInstall

I can't tell for the Python version needed for CS, but as you mentioned it is probably a good idea to start using the CS 2.0 candidate branch instead of CS 1.4
Logged
Squirrel-the-tire
Newbie
*
Posts: 7


View Profile Email
« Reply #6 on: February 07, 2011, 11:38:50 pm »

Is there a binary in a zip instead of the installer for blender 2.49 with python 2.5?
Logged
Squirrel-the-tire
Newbie
*
Posts: 7


View Profile Email
« Reply #7 on: February 07, 2011, 11:54:46 pm »

Nevermind, I just used 7zip to extract the installer. ;P
Logged
Pages: [1] Print 
« previous next »
Jump to:  

Powered by MySQL Powered by PHP Powered by SMF 1.1.2 | SMF © 2006-2007, Simple Machines LLC Valid XHTML 1.0! Valid CSS!
Page created in 4.464 seconds with 16 queries.