Crystal Space
Welcome, Guest. Please login or register.
December 18, 2014, 08:30:31 am

Login with username, password and session length
Search:     Advanced search
9032 Posts in 2046 Topics by 9287 Members
Latest Member: Mariaiuwaga
* Home Help Search Login Register
+  Crystal Space
|-+  Crystal Space Development
| |-+  Support
| | |-+  Problem at compiling,
« previous next »
Pages: [1] Print
Author Topic: Problem at compiling,  (Read 1519 times)
phytone
Newbie
*
Posts: 3


View Profile Email
« on: September 06, 2012, 08:18:00 am »

Hi everyone,
I used to work with other libraries but now i want to try crystal space and as far as i've seen, its one of the best engines that i can trust,
anyway, i'm using an x86_64 Kubuntu, i'm getting this error below while compiling,

Code:
    g++ -c -o ./out/linux/optimize/plugins/physics/odedynam/odedynam.o -I/home/sinan/Proje/CS/. -I./include -I/home/sinan/Proje/CS/./include -pipe -Wall -Wno-unknown-pragmas -fvisibility=hidden -mtune=generic -mfpmath=sse -I/usr/local/include -DNVALGRIND -fno-exceptions -fvisibility-inlines-hidden -DNVALGRIND -ffunction-sections -fdata-sections -O3 -fomit-frame-pointer -ffast-math -g2 -fPIC -DdSINGLE -I/usr/local/include  /home/sinan/Proje/CS/plugins/physics/odedynam/odedynam.cpp

/home/sinan/Proje/CS/plugins/physics/odedynam/odedynam.cpp: In member function ‘virtual void CS::Plugin::odedynam::csODEDynamicSystem::Step(float)’:
/home/sinan/Proje/CS/plugins/physics/odedynam/odedynam.cpp:814:49: error: ‘dWorldStepFast1’ was not declared in this scope
...skipped odedynam.so for lack of <plugins!physics!odedynam!>odedynam.o...
make: *** [all] Error 1

do you have any ideas, i can just edit the source of odedynam.cpp but thats not the way i think and i dont want to mess with the code.
Logged
jorrit
Administrator
Hero Member
*****
Posts: 1706


View Profile
« Reply #1 on: September 07, 2012, 08:01:53 am »

Hi everyone,
I used to work with other libraries but now i want to try crystal space and as far as i've seen, its one of the best engines that i can trust,
anyway, i'm using an x86_64 Kubuntu, i'm getting this error below while compiling,

Code:
    g++ -c -o ./out/linux/optimize/plugins/physics/odedynam/odedynam.o -I/home/sinan/Proje/CS/. -I./include -I/home/sinan/Proje/CS/./include -pipe -Wall -Wno-unknown-pragmas -fvisibility=hidden -mtune=generic -mfpmath=sse -I/usr/local/include -DNVALGRIND -fno-exceptions -fvisibility-inlines-hidden -DNVALGRIND -ffunction-sections -fdata-sections -O3 -fomit-frame-pointer -ffast-math -g2 -fPIC -DdSINGLE -I/usr/local/include  /home/sinan/Proje/CS/plugins/physics/odedynam/odedynam.cpp

/home/sinan/Proje/CS/plugins/physics/odedynam/odedynam.cpp: In member function ‘virtual void CS::Plugin::odedynam::csODEDynamicSystem::Step(float)’:
/home/sinan/Proje/CS/plugins/physics/odedynam/odedynam.cpp:814:49: error: ‘dWorldStepFast1’ was not declared in this scope
...skipped odedynam.so for lack of <plugins!physics!odedynam!>odedynam.o...
make: *** [all] Error 1

do you have any ideas, i can just edit the source of odedynam.cpp but thats not the way i think and i dont want to mess with the code.


What version of CS and bullet?

Greetings,
Logged
phytone
Newbie
*
Posts: 3


View Profile Email
« Reply #2 on: September 07, 2012, 08:43:47 am »

Thanks for the reply;

Actually both current snapshot (snapshot of yesterday) and latest stable version 2.0 are giving me the same error. Definitely there is sth wrong with my system, on the other hand, i used to have ode libraries installed on my system so i thought there may be some conflicts and i uninstalled it and tried again, still no luck..

and about bullet, i dont have bullet physics installed;

this is the output of my configuration results;
Code:
******************************************************************************
***                 Crystal Space -- Configuration Summary                 ***
******************************************************************************
Build mode: optimize
Version: 2.1 (SVN: no)

Optional Dependencies
---------------------
Found
  3ds                  (models)
  assimp               (models)
  cal3d                (models)
  cegui                (gui)
  freetype2            (other)
  jpeg                 (image)
  lcms                 (image)
  linux-joystick       (other)
  mng                  (image)
  ode                  (physics)
  opengl               (rendering)
  oss                  (audio)
  png                  (image)
  python               (bindings)
  x11                  (rendering)
  zlib                 (other)

Missing
  alsa                 (audio)
  bullet               (physics)
  cairo                (image)
  cairomm              (image)
  cg                   (rendering)
  curl                 (other)
  gtk                  (other)
  jackasyn             (audio)
  java                 (bindings)
  ogg                  (audio)
  openal               (audio)
  perl                 (bindings)
  speex                (audio)
  vgvm                 (image)
  vorbis               (audio)
  wxwidgets            (gui)

Logged
jorrit
Administrator
Hero Member
*****
Posts: 1706


View Profile
« Reply #3 on: September 07, 2012, 08:45:52 am »

Ah ODE, I recommend not using the ODE plugin anymore. Bullet is much better supported by us. I think the problem is caused by you having the wrong version of ODE on your system but as I said, use bullet instead.

Greetings,
Logged
phytone
Newbie
*
Posts: 3


View Profile Email
« Reply #4 on: September 07, 2012, 08:53:18 am »

yes, i know bullet from blender and its better, the point was, i had some old projects that i wrote with ode, maybe its time to rewrite them and integrate bullet to them,

now i'm compiling bullet 2.8 and getting rid of ode,

thanks for your advice, i will post the details if this solves my situation.

best regards
Logged
Pages: [1] Print 
« previous next »
Jump to:  

Powered by MySQL Powered by PHP Powered by SMF 1.1.2 | SMF © 2006-2007, Simple Machines LLC Valid XHTML 1.0! Valid CSS!
Page created in 7.293 seconds with 17 queries.