Crystal Space
Welcome, Guest. Please login or register.
December 22, 2014, 12:28:02 pm

Login with username, password and session length
Search:     Advanced search
9032 Posts in 2046 Topics by 9302 Members
Latest Member: Janrdym
* Home Help Search Login Register
+  Crystal Space
|-+  Crystal Space Development
| |-+  Support
| | |-+  Install help windows 7 visual studio 2010 express
« previous next »
Pages: [1] Print
Author Topic: Install help windows 7 visual studio 2010 express  (Read 1933 times)
Shiv05
Newbie
*
Posts: 3


View Profile Email
« on: June 14, 2013, 04:15:10 pm »

I have been trying to install CS since 2.5 days but have not yet been able to install it. This is what I am doing

1.I downloaded and extracted the crystal space 3D version 2.0 and downloaded the associated cs-winlibs (64 bit).
2. I installed cs-winlibs.(VC Typical install)
3. I opened the MVS solution wkstypical in mk/msvc10
4. To include external headers and add libraries, I am making changes in the "Microsoft.Cpp.Win32.user" property sheet.
      a) In Microsoft.Cpp.Win32.user -> properties -> Common Properties-> C/C++ -> general ->Additional Include Directories I added 2 paths
                            C:\shivoam\gameattempt\cs3d\crystalspace-src-2.0\winlibs\x64\include      and
                            C:\shivoam\gameattempt\cs3d\crystalspace-src-2.0\include
      b) In Microsoft.Cpp.Win32.user -> properties -> Common Properties -> Linker -> general -> Additional Library Directories I added 2 paths
                            C:\shivoam\gameattempt\cs3d\crystalspace-src-2.0\winlibs\x64\lib
                            C:\shivoam\gameattempt\cs3d\crystalspace-src-2.0\libs
5. When I build the project, I get a bunch of LN2019, LNK2001 and LNK1112 errors. Here is the link to the complete output build
http://pastebin.com/UNrttM87

SOMEBODY HELP!!
Logged
Sazanami
Newbie
*
Posts: 1


View Profile Email
« Reply #1 on: June 14, 2013, 09:50:38 pm »

Hey Shiv05,

I noticed your situation looked a lot like mine. (Including the spending the 2.5 days part Tongue) The only difference being that I set the include and library paths in:
properties --> Configuration Properties --> VC++ Directories

Anyway, your output was also disturbingly similar to mine, so I figured you might want to know how I got my build to execute without errors.
Originally, I downloaded the cs-winlibs-x64-2.1_003.exe file from the following page:
http://www.crystalspace3d.org/docs/online/manual-2.0/MSVC7.html#0

My errors disappeared after uninstalling the above 2.1 version of cs-winlibs and installing the latest 2.0 version from this page:
http://www.crystalspace3d.org/downloads/cs-winlibs/

Now that I take another look at the file I downloaded, I realize it wasn't the 64 bit version that I downloaded and installed, but the regular one.
In other words, I got it to work by installing cs winlibs using the file called: cs-win32libs-2.0_002.exe

I hope this helps.


Edit: I just realized that next to the "DebugWithDlls" I never switched from 'Win32' to 'x64'. It's late, so I am not going to test it anymore, but I assume that is why my build succeeded with the normal version of cs winlibs.
« Last Edit: June 14, 2013, 10:55:19 pm by Sazanami » Logged
Shiv05
Newbie
*
Posts: 3


View Profile Email
« Reply #2 on: June 16, 2013, 02:02:51 pm »

Got it working!!!
Installed winlibs 32 bit version and it worked wothout any problems....Smiley
Thanks for the help!
Logged
Pages: [1] Print 
« previous next »
Jump to:  

Powered by MySQL Powered by PHP Powered by SMF 1.1.2 | SMF © 2006-2007, Simple Machines LLC Valid XHTML 1.0! Valid CSS!
Page created in 6.459 seconds with 15 queries.