Crystal Space
Welcome, Guest. Please login or register.
November 29, 2014, 03:35:19 am

Login with username, password and session length
Search:     Advanced search
9026 Posts in 2046 Topics by 9158 Members
Latest Member: Virginiarude
* Home Help Search Login Register
+  Crystal Space
|-+  Crystal Space Development
| |-+  General Crystal Space Discussion
| | |-+  I am having problems
« previous next »
Pages: [1] 2 Print
Author Topic: I am having problems  (Read 7559 times)
Dunken
Guest


Email
« on: November 06, 2005, 01:47:44 am »

i am trying to compile crystal space with cygwin but it wont work somone please tell me how to compile it
Logged
sunshine
Administrator
Sr. Member
*****
Posts: 294


View Profile
« Reply #1 on: November 06, 2005, 01:56:13 am »

It would be a good idea to provide more information about precisely what doesn't work.
Logged
Dunken
Guest


Email
« Reply #2 on: November 06, 2005, 03:12:05 am »

sure thing i type ./configure after cd ing my dirrectory and i get this

Owner@UPSTAIRS /c/cs
$ ./configure
checking build system type... i686-pc-mingw32
checking host system type... i686-pc-mingw32
checking for gcc... no
checking for cc... no
checking for cc... no
checking for cl... no
configure: error: no acceptable C compiler found in $PATH
See `config.log' for more details.


then nothing else works
Logged
Dunken
Guest


Email
« Reply #3 on: November 06, 2005, 03:15:03 am »

oh and i used Cygwin
Logged
muffinpeddler
Full Member
***
Posts: 122


View Profile Email
« Reply #4 on: November 06, 2005, 03:34:39 am »

you need to install gcc and g++ in cygwin.  Run the cygwin setup exe again so you can chose the packages...
Logged
Dunken
Guest


Email
« Reply #5 on: November 06, 2005, 04:51:56 am »

well that solved the configure problems

but when i put the

 make -k all

command it says


bash: make: command not found

i suppose i need to install somthing else so would somone tell me what to install or what else to do

Thank you
Logged
sunshine
Administrator
Sr. Member
*****
Posts: 294


View Profile
« Reply #6 on: November 06, 2005, 05:33:40 am »

You would want to install 'make'. Also be sure that you installed cs-win32libs. Note that you can probably get results more simply by using Mingw+Msys as documented in the CS manual. Mingw+Msys is well-supported by CS, and it's typically simpler to install Mingw+Msys than Cygwin.
Logged
Dunken
Guest


Email
« Reply #7 on: November 06, 2005, 07:45:23 pm »

now it knows make but i get the message

$ make -k all
make: *** No rule to make target 'all'.
Logged
sunshine
Administrator
Sr. Member
*****
Posts: 294


View Profile
« Reply #8 on: November 07, 2005, 02:32:57 pm »

This could happen if the configure script didn't run correctly. For instance, if it reported that it was unable to set up the 'make emulation layer', you would experience this problem.
Logged
Dunken
Guest


Email
« Reply #9 on: November 11, 2005, 04:46:39 am »

well i cot it complied i installed everything of the 500 mb cygwin and it worked but when i try to run anything i complied i get the message


This application has failed to start because cygwin1.dll was not forund. Re-installing the application may fix this problem

and all applications i complied get the same message

Please help me
Logged
sunshine
Administrator
Sr. Member
*****
Posts: 294


View Profile
« Reply #10 on: November 11, 2005, 06:11:47 am »

Make sure that your PATH mentions the directory containing cygwin1.dll, which is distributed with Cygwin. Alternately, copy cygwin1.dll into some directory mentioned by your PATH.
Logged
Dunken
Guest


Email
« Reply #11 on: November 21, 2005, 03:45:12 am »

I am having more problems now when i try to start crystal space it makes a microsecond flash of some message the ends the program. all i realy see is

"Missing 3d graphics pluging"

where do you get the 3d graphics plugin?
Logged
sunshine
Administrator
Sr. Member
*****
Posts: 294


View Profile
« Reply #12 on: November 21, 2005, 02:42:22 pm »

The 3D renderer plugin should be built as part of the compile process. If you are lacking the OpenGL developer headers/libraries, then the OpenGL renderer may not have been built. (You will need to see the output of configure to find out if the OpenGL check failed.) At any rate, the software renderer should have built. You can tell programs to instead use the software renderer by using the command-line argument --video=software when you run each program.

You may be able to get more useful output if you build in debug mode, or if you use the --console switch when running the programs. Another useful option is --verbose, though it tends to spit out quite a bit of information. You could try --verbose=scf to limit it being verbose only about SCF.
Logged
Dunken
Guest


Email
« Reply #13 on: November 27, 2005, 09:39:01 pm »

Well i tried all of that and still receved th same message. the verbose gave me a bunbch of lines of crud then quit
Logged
sunshine
Administrator
Sr. Member
*****
Posts: 294


View Profile
« Reply #14 on: November 27, 2005, 11:05:08 pm »

You'll need to look at the output of --verbose to see where CS was looking and to find out which plugins it actually found.
Logged
Pages: [1] 2 Print 
« previous next »
Jump to:  

Powered by MySQL Powered by PHP Powered by SMF 1.1.2 | SMF © 2006-2007, Simple Machines LLC Valid XHTML 1.0! Valid CSS!
Page created in 4.329 seconds with 16 queries.