Crystal Space
Welcome, Guest. Please login or register.
October 01, 2014, 09:13:34 am

Login with username, password and session length
Search:     Advanced search
9020 Posts in 2053 Topics by 8564 Members
Latest Member: Gwennparks5
* Home Help Search Login Register
+  Crystal Space
|-+  Crystal Space Development
| |-+  Support
| | |-+  newb question, compiling w/ vs c++ 8 - application error
« previous next »
Pages: [1] Print
Author Topic: newb question, compiling w/ vs c++ 8 - application error  (Read 3693 times)
tadm
Newbie
*
Posts: 2


View Profile
« on: December 17, 2005, 12:16:12 am »

Hi all,

I am just starting out, and wanted to get cs to compile in vs c++ 8 express.  is there any instructions?

I can compile the code, yet when I go to run the app, say walktest.exe, I have an error cannot find "msvcr80d.dll", so I find it, copy it over.  When I run the app again, I get an application error.

Can someone breifly tell me how to fix this? What am I doing wrong?

Ta
Logged
sunshine
Administrator
Sr. Member
*****
Posts: 294


View Profile
« Reply #1 on: December 18, 2005, 01:24:14 am »

Did you install the MS Platform SDK by following the MS instructions precisely?
Logged
tadm
Newbie
*
Posts: 2


View Profile
« Reply #2 on: December 18, 2005, 01:36:23 am »

I thought I did it precisely, I will do it again.  I will post if I get it to work.
Logged
siggyuke
Newbie
*
Posts: 6


View Profile Email
« Reply #3 on: January 17, 2006, 11:51:49 am »

Hi

Is there an answer to this problem?

I've just downlaoded, installed and compiled 'Latest Pseudo Stable Release (0.99 from 3 September 2005)'.
I'm using MS VisStudio 2005 to compile, which went like a dream (or seemed to Shocked).

I tried to run the walk app and I got 'unable to find msvcr80d.dll'. 
I found this on my system, copied it to the app directory.
Tried to run it again and got 'unable to find coredll.dll', which isn't on my system.

Any advice would be most appreciated.

Thanks in advance

Siggyuke
Logged
snnicko
Newbie
*
Posts: 28


Pyromaniacal Psychopath


View Profile
« Reply #4 on: January 17, 2006, 04:36:24 pm »

You are using the CVS version right? Otherwise download a CVS client (if you are on windows I recommend TortoiseCVS and recompile. There was a post about this recently at http://community.crystalspace3d.org/forum/index.php/topic,542.0.html.
Logged
siggyuke
Newbie
*
Posts: 6


View Profile Email
« Reply #5 on: January 17, 2006, 05:13:25 pm »

Hi snnicko

nope, I was trying to use 'Latest Pseudo Stable Release (0.99 from 3 September 2005)', rather than cvs.
As I thought......  well not sure why, just thought it'd be easier than using CVS.

So do you have to use CVS version to compile & run in vs2005?

Oh, and thanks for the link. 
I had seen it, but thought this thread was newer & offered more info - & so started this one up again.

Thanks again.

Siggyuke
« Last Edit: January 17, 2006, 05:16:50 pm by siggyuke » Logged
snnicko
Newbie
*
Posts: 28


Pyromaniacal Psychopath


View Profile
« Reply #6 on: January 17, 2006, 05:17:09 pm »

According to the post I mentioned above CVS works. At present I am recompiling mine with CVS to find out. I will get in touch if it works.

It appears a common misconception is that CVS is hard to use. If you use TortoiseCVS from http://prdownloads.sourceforge.net/tortoisecvs/TortoiseCVS-1.8.24.exe then open the folder above where you extracted crystal space, right click the CS folder and select 'Update'. After this you need to open CS/mk/msvc8/wkstypical.sln and press F7.
« Last Edit: January 17, 2006, 05:40:01 pm by snnicko » Logged
snnicko
Newbie
*
Posts: 28


Pyromaniacal Psychopath


View Profile
« Reply #7 on: January 17, 2006, 07:09:05 pm »

Yes, the CVS version works
Logged
dingobloo
Idle Extrordinare.
Global Moderator
Full Member
*****
Posts: 125


View Profile WWW
« Reply #8 on: January 18, 2006, 06:17:32 am »

When the psuedo stable was released MSVC 8.0 was in beta, and so was not officially supported, hence no win32libs to cover that.
Logged
siggyuke
Newbie
*
Posts: 6


View Profile Email
« Reply #9 on: January 18, 2006, 12:48:58 pm »

Hi Guys

thanks for the replies, they're most appreciated.

I'll try getting the CVS version (via TortoiseCVS Smiley ) and compile.

Thanks again guys.

Siggyuke

--------------------------
Just tried the TortoiseCVS -> update method and I get:

Empty password used - try 'cvs login' with a real password
can't create temporary directory /tmp/cvs-serv12419
Too many links

Error, CVS operation failed

doh!!!! 

« Last Edit: January 18, 2006, 01:05:52 pm by siggyuke » Logged
snnicko
Newbie
*
Posts: 28


Pyromaniacal Psychopath


View Profile
« Reply #10 on: January 18, 2006, 06:11:31 pm »

I have had that as well, and my setup used to work.

OK, plan B, to get crystal space for now go to http://crystalspace3d.org/cvs-snapshots/zip/cs-current-snapshot.zip and keep trying CVS. Hopefully it is a problem which will be resolved soon.
Logged
siggyuke
Newbie
*
Posts: 6


View Profile Email
« Reply #11 on: January 19, 2006, 10:54:04 am »

Hi snnicko

thanks for the reply (again Smiley ).

It's always nice to know that problems I run into are not just down to me being stupid Smiley

Yes, I downloaded the daily snap shot when CVS didn't work. 
It compiled and the walktest app ran up.
So I seem to be in business!

Cheers

Siggyuke
Logged
Pages: [1] Print 
« previous next »
Jump to:  

Powered by MySQL Powered by PHP Powered by SMF 1.1.2 | SMF © 2006-2007, Simple Machines LLC Valid XHTML 1.0! Valid CSS!
Page created in 7.447 seconds with 16 queries.