Crystal Space
Welcome, Guest. Please login or register.
December 19, 2014, 05:49:14 am

Login with username, password and session length
Search:     Advanced search
9032 Posts in 2046 Topics by 9288 Members
Latest Member: Lorrainewhite
* Home Help Search Login Register
+  Crystal Space
|-+  Crystal Space Development
| |-+  Support
| | |-+  Playing an opening video
« previous next »
Pages: [1] Print
Author Topic: Playing an opening video  (Read 2846 times)
bernardofd
Jr. Member
**
Posts: 74


59948732 bernardofd@click21.com.br
View Profile WWW
« on: February 01, 2006, 06:37:52 pm »

Hello!

I need to play an opening video in my CS/CEL app. I've quickly searched the manual, APIs, community site, this forum and etcs but I didn't find anything usefull.

In fact, I have a little MPEG movie file which I want to load and play as soon as my application loads everything (I think before the call of the function Run( ) in App::Application( ) method) but I don't have a clue in how to do it.

Help is appreciated. Wink

Thanks in advance

Logged

__________________________
Bernardo Figuerêdo Domingues
Computer Science - UFMG - Brazil
bernardofd
Jr. Member
**
Posts: 74


59948732 bernardofd@click21.com.br
View Profile WWW
« Reply #1 on: February 01, 2006, 09:03:16 pm »

Hey... Nevermind... I think I get it, just looking at the file $CRYSTAL\apps\video\video.cpp. Smiley

It still lacks a test, because my intro movie was in MPEG format. Does CS have any other video codecs than avi (DivX and others)?

Regards!
Logged

__________________________
Bernardo Figuerêdo Domingues
Computer Science - UFMG - Brazil
bernardofd
Jr. Member
**
Posts: 74


59948732 bernardofd@click21.com.br
View Profile WWW
« Reply #2 on: February 02, 2006, 07:44:01 pm »

Argh! Codec's issue...

Well, I've researched a lot and I realized that the codecs for opening DivX, XviD, or OpenDivX are missing. I've downloaded and installed several and several of these (including a div4linux dated od april 2002!) bur the CS's configure script keep saying that the codec is not installed.

What I want to know is what package should I get and install for this video playback work...

Thanks in advance
Logged

__________________________
Bernardo Figuerêdo Domingues
Computer Science - UFMG - Brazil
jorrit
Administrator
Hero Member
*****
Posts: 1706


View Profile
« Reply #3 on: February 02, 2006, 09:11:41 pm »

I'm afraid that video playback feature was not working properly. It has even been removed from CS in more recent versions.

Greetings,
Logged
bernardofd
Jr. Member
**
Posts: 74


59948732 bernardofd@click21.com.br
View Profile WWW
« Reply #4 on: February 02, 2006, 09:24:46 pm »

Well, sad to hear that... But is there any way to play a video through CS? Or I would have to make a call to a player (example, call mplayer)?

In fact, in pseudo-stable september-3rd it still have the structures to video playing (iVideoStream, and etcs...)

Thanks and Regards
Logged

__________________________
Bernardo Figuerêdo Domingues
Computer Science - UFMG - Brazil
jorrit
Administrator
Hero Member
*****
Posts: 1706


View Profile
« Reply #5 on: February 02, 2006, 09:45:24 pm »

Well, sad to hear that... But is there any way to play a video through CS? Or I would have to make a call to a player (example, call mplayer)?

In fact, in pseudo-stable september-3rd it still have the structures to video playing (iVideoStream, and etcs...)

Thanks and Regards

Using the iGraphics3D->SetRenderTarget() method one can render on any texture you want. Using that one can probably make code to read a video and then put that on the texture.

Greetings,
Logged
allpowerful32
Jr. Member
**
Posts: 62


View Profile
« Reply #6 on: February 03, 2006, 03:00:19 am »

How salvagable is the video streaming code from that old video plugin?  I have a similar goal, and I don't want to rewrite all of that.
Logged
Pages: [1] Print 
« previous next »
Jump to:  

Powered by MySQL Powered by PHP Powered by SMF 1.1.2 | SMF © 2006-2007, Simple Machines LLC Valid XHTML 1.0! Valid CSS!
Page created in 4.226 seconds with 15 queries.