Crystal Space
Welcome, Guest. Please login or register.
July 31, 2014, 04:51:03 am

Login with username, password and session length
Search:     Advanced search
9005 Posts in 2043 Topics by 8262 Members
Latest Member: Emilymoore
* Home Help Search Login Register
+  Crystal Space
|-+  Associate Projects
| |-+  CrystalBlend Discussion
| | |-+  Start and build problems
« previous next »
Pages: [1] Print
Author Topic: Start and build problems  (Read 9039 times)
Ernie
Newbie
*
Posts: 21


View Profile
« on: February 10, 2006, 11:37:19 am »

Hi,

I wanted to try crystalblend and downloaded the lite version. when I wanted to start I got the following error:
- g:\cs\sndmanager.dll plugin compiler does not match application compiler VisulaC != GCC.

So I downloaded the current cvs version and wanted to build it as described in the README.
I got the following error :
fatal error C1083: cant open include file : "config.h": No such file or directory   e:\Download\KI\crystalblend_win32_0.02\crystalblend\src\readblend\dnapp\variable.cpp   1

can someone help ?

Thx
Ernie
Logged
jorrit
Administrator
Hero Member
*****
Posts: 1706


View Profile
« Reply #1 on: February 10, 2006, 02:01:34 pm »

Hi,

I wanted to try crystalblend and downloaded the lite version. when I wanted to start I got the following error:
- g:\cs\sndmanager.dll plugin compiler does not match application compiler VisulaC != GCC.

How are you starting CrystalBlend? Using the '.cmd' scripts? You should do that as they make sure the env vars are correct.

Quote
So I downloaded the current cvs version and wanted to build it as described in the README.
I got the following error :
fatal error C1083: cant open include file : "config.h": No such file or directory   e:\Download\KI\crystalblend_win32_0.02\crystalblend\src\readblend\dnapp\variable.cpp   1

can someone help ?

Thx
Ernie

Perhaps the MSVC project files are outdated. I'll have to look at that again.

Greetings,
Logged
Ernie
Newbie
*
Posts: 21


View Profile
« Reply #2 on: February 10, 2006, 03:17:33 pm »

Yes I use the [start_goodhardware.cmd] to start it...

Thanks for checking the project files.
Logged
jorrit
Administrator
Hero Member
*****
Posts: 1706


View Profile
« Reply #3 on: February 10, 2006, 03:18:39 pm »

Yes I use the [start_goodhardware.cmd] to start it...

Hmm. strange that should work. I have no idea why it is giving that problem sad
Nobody else reported a problem like that.

Greetings,
Logged
Ernie
Newbie
*
Posts: 21


View Profile
« Reply #4 on: February 10, 2006, 03:41:20 pm »

I seems that the error that comes when I start  [start_goodhardware.cmd] tells that its a problem that
g:\cs\sndmanager.dll was built with MSVS 8.0 and CrystalBlend was built witch GCC.

This seems to be a problem for CrystalBlend.
Logged
jorrit
Administrator
Hero Member
*****
Posts: 1706


View Profile
« Reply #5 on: February 10, 2006, 03:42:48 pm »

I seems that the error that comes when I start  [start_goodhardware.cmd] tells that its a problem that
g:\cs\sndmanager.dll was built with MSVS 8.0 and CrystalBlend was built witch GCC.

This seems to be a problem for CrystalBlend.

But why is it using g:\cs\sndmanager.dll? It shouldn't use that. The start_goodhardware.cmd script should change the CRYSTAL environment variable so that it points to the CrystalBlend directory. So the dll's in g:\cs\sndmanager.dll shouldn't be used.

Greetings,
Logged
Ernie
Newbie
*
Posts: 21


View Profile
« Reply #6 on: February 10, 2006, 06:53:23 pm »

ahh now I see what you want to do.
But the command SET CRYSTAL . and SET CEL . does not have any effect in the WindowsXP CMD shell.
It just displays the values of CRYSTAL and CEL.
Logged
Ernie
Newbie
*
Posts: 21


View Profile
« Reply #7 on: February 10, 2006, 08:25:30 pm »

I modified the start_goodhardware.cmd file that it fits for WindowsXP and should also work other OS that prefer the former style :

cd prg
ver | Find "XP" >NUL 
If Not ErrorLevel 1 GOTO :WinXP      
  GOTO :OtherOS
 
:WinXP
  Echo OS is Windows XP
  set CRYSTAL=%cd%
  set CEL=%cd% 
  crystalblend.exe normalmap.blend -mode=1024x768 -silent
  GOTO :EOF
 
:OtherOS
   Echo OtherOS
  set CRYSTAL .
  set CEL .
  crystalblend.exe normalmap.blend -mode=1024x768 -silent
:EOF

Have a nice weekend
-Ernie
Logged
jorrit
Administrator
Hero Member
*****
Posts: 1706


View Profile
« Reply #8 on: February 10, 2006, 08:36:24 pm »

ahh now I see what you want to do.
But the command SET CRYSTAL . and SET CEL . does not have any effect in the WindowsXP CMD shell.
It just displays the values of CRYSTAL and CEL.

Strange. I made that script on WindowsXP myself (i.e. the entire distribution was made on WindowsXP) and it works fine there. Strange that it doesn't work for you.

Greetings,
Logged
Pages: [1] Print 
« previous next »
Jump to:  

Powered by MySQL Powered by PHP Powered by SMF 1.1.2 | SMF © 2006-2007, Simple Machines LLC Valid XHTML 1.0! Valid CSS!
Page created in 6.18 seconds with 18 queries.