Crystal Space
Welcome, Guest. Please login or register.
September 01, 2014, 03:35:42 pm

Login with username, password and session length
Search:     Advanced search
9009 Posts in 2043 Topics by 8372 Members
Latest Member: Berger4
* Home Help Search Login Register
  Show Posts
Pages: [1]
1  Crystal Space Development / Support / Stuck on Simple1 on: May 06, 2005, 06:36:39 pm
I am running VC++ 7.  I tried installing the newest version of win32Libs, no apparent change.  I even recompiled CS again with the new win32Libs, just to see if it would make any difference.

I tried removing the files from the list one by one.  Each time the filename changes in the build error until i take out the last one and it goes crazy and spouts a billion errors.

Here is the exact build error.  I've tried it with the debug version and only the name of the lib changes.

Quote
------ Build started: Project: simple1, Configuration: Debug Win32 ------

Compiling...
simple1.cpp
Linking...
LINK : fatal error LNK1104: cannot open file 'libcsutil.lib'

Build log was saved at "file://c:\Cs\simpleCS\simple1\Debug\BuildLog.htm"
simple1 - 1 error(s), 0 warning(s)


---------------------- Done ----------------------

    Build: 0 succeeded, 1 failed, 0 skipped



I tried removing the path information to where the libs are located, and There was no change to the error message, which confused me.  Since you would think it would whine alot more.  So it's almost like it can't find them at all.

So i tried copying and pasting the Libs from CS\mk\visualc7\csrelease\bin\libs to my CS\include folder.  Since i know it's seeing that folder since it's reading all of those include files from it.  But this had no apparent change.

I'm going to try just remaking a brand new solution in Visual Studio and remake it from scratch.  See if that fixes the problem.
2  Crystal Space Development / Support / Stuck on Simple1 on: May 01, 2005, 08:50:03 am
I was following the directions at http://crystalspace3d.org/docs/online/manual-0.98/cs_127.html to make the simple1 app.

But i get the error below when i compile it.
simple1 fatal error LNK1104: cannot open file 'libcsutil.lib'

If i change the order of the files in the Additional Dependencies field and put a different file in front then it will show that one as not being openable.

Additional Dependencies field currently says: libcsutil.lib libcsgeom.lib libcsgfx.lib libcstool.lib

my cpp and .h files are exactly what came when i downloaded the CS, i've reextracted the zip, and recoppied them over.  Tried recompileing a debug and a release of CS.  Get the same error when i use the debug version except for it says libcsutil_d.lib since it's debug.

I've double checked the presence of the path to the files under VC++ Directories, in the options page.

I have the Preprocessor information entered correctly.

I have runtime library set to use Multi-threaded DLL (/MD)

I downloaded it, extracted it.  Installed the cs-win32libs-0.98r004_001.exe and then compiled CS.  It works fine.  All the compiled demos work great.

Where am i screwing up?
Pages: [1]
Powered by MySQL Powered by PHP Powered by SMF 1.1.2 | SMF © 2006-2007, Simple Machines LLC Valid XHTML 1.0! Valid CSS!
Page created in 4.144 seconds with 17 queries.