Crystal Space
Welcome, Guest. Please login or register.
September 20, 2014, 02:57:06 am

Login with username, password and session length
Search:     Advanced search
9018 Posts in 2051 Topics by 8484 Members
Latest Member: Msnatecarleen0303
* Home Help Search Login Register
  Show Posts
Pages: [1]
1  Crystal Space Development / Game Content Creation / Re: blender2crystal woes on: March 05, 2008, 09:13:18 pm
Ok, so I got the RoomTest.blend example from the site.  It exported just fine, and loaded up into walktest, everything displays cleanly, in color, good to go.

So apparently i'm doing something wrong (or not doing something at all) in blender.
Hrm...
2  Crystal Space Development / Game Content Creation / blender2crystal woes on: March 03, 2008, 09:09:08 pm
Greetings, I've been playing with blender and crystal again lately, and have run into a pretty consistent issue...

So I may create some nice scene in blender (let's say a room with nice colorful walls)
Then I export it using blender2cs which makes world.zip
Then I extract world.zip and walktest -relight .

Now all this goes fairly well, I get a camera that moves around walktest style.

What doesn't go so well is that the lights seem VERY VERY dim, and not at all where I placed them in blender.

Also, I either see no color (materials) or sometimes (maybe by cranking the lights up REALLY bright and putting them REALLY close) i'll get kind of an average color.  So for example a leopard print jpg tex'd onto a wall will just look like flat solid tan.

Sometimes (like just now), however, I just get blackness.  In nothing more than a cube with a light and a camera in it (and yes the normals are flipped in).
It renders properly (beautifully) in blender, but when I open it in cs, not so much.


Any help getting over this little bump would be greatly appreciated
Thx
3  Crystal Space Development / Support / Assistance with includes and libraries search paths mingw/msys on: November 10, 2007, 08:02:14 am
Greetings, I'm the newest noob,
I can download configure, and jam and even jam install all without errors, and all by the install proceedure.
All of the samples run just fine.

My problem is that i'm now trying to create my first simple stuff, following the simple tutorial in the documentation.
I already cannot compile it manually using g++.  It can't find crystalspace.h  I have tried throwing -I/path/to/includes and then it complains about undefined other things so when i do -l/path/to/lib those go away but it still has errors.

I extract and jam crystal in /c/cs  that is also what $CRYSTAL is set to
And when i have tried jam install it puts stuff in /usr/local/...
Either of these configurations I cannot get to work.

I suspect that I have done something wrong along the way... Or perhaps i'm missing some big clue in the writing of my first little app.
Do I have to set LIBRARY_PATH LD_LIBRARY_PATH etc etc?

Or am I missing an even more important clue somewhere?

Thanks!

Pardon,
MinGW-5.1.3
MSYS-1.0.10
cs-win32libs-1.2_002
crystalspace-src-1.2
win xp sp2
Pages: [1]
Powered by MySQL Powered by PHP Powered by SMF 1.1.2 | SMF © 2006-2007, Simple Machines LLC Valid XHTML 1.0! Valid CSS!
Page created in 4.311 seconds with 17 queries.