Crystal Space
Welcome, Guest. Please login or register.
November 25, 2014, 02:06:56 am

Login with username, password and session length
Search:     Advanced search
9018 Posts in 2046 Topics by 9111 Members
Latest Member: Jorak
* Home Help Search Login Register
+  Crystal Space
|-+  Crystal Space Development
| |-+  Support
| | |-+  Compiling issue
« previous next »
Pages: [1] 2 3 Print
Author Topic: Compiling issue  (Read 18021 times)
namiz
Newbie
*
Posts: 26


View Profile Email
« on: April 18, 2006, 04:32:22 pm »

Im really confused...

I tried using Msys to compile but i keep on getting this stupid error message saying that there is no such destination..

I dont have Microsoft Visual, so i was wondering if there was any other way to compile it.

Thanks,
Nate
Logged
jorrit
Administrator
Hero Member
*****
Posts: 1706


View Profile
« Reply #1 on: April 18, 2006, 05:40:38 pm »

Im really confused...

I tried using Msys to compile but i keep on getting this stupid error message saying that there is no such destination..

I dont have Microsoft Visual, so i was wondering if there was any other way to compile it.

Thanks,
Nate

Can you be a bit more specific and copy paste the exact error here? Also the commands you are doing.

Greetings,
Logged
namiz
Newbie
*
Posts: 26


View Profile Email
« Reply #2 on: April 18, 2006, 08:25:45 pm »

Ok in the tutorial, heres the link
http://crystalspace3d.org/docs/online/manual/cs_2.4.4.php#2.4.4

"At the shell prompt, go to your `CS' directory with the `cd' command. For example, if Crystal Space resides at `C:\work\CS', invoke the command `cd /c/work/CS'. Next, configure and build the project with the following sequence of commands: "

I type cd C:\Documents and Settings\Owner\Desktop\crystal\CS

and it says the following:

sh: cd: C:Documents: No such file or directory
Logged
jorrit
Administrator
Hero Member
*****
Posts: 1706


View Profile
« Reply #3 on: April 18, 2006, 08:31:28 pm »

Well you are not doing what the manual says. The manual says:
'if Crystal Space resides at `C:\work\CS', invoke the command `cd /c/work/CS'.

So you should not type:

cd C:\Documents and Settings\Owner\Desktop\crystal\CS

But you should type:

cd /c/Documents and Settings/Owner/Desktop/crystal/CS

i.e. you must use the msys syntax for paths.

In general it is probably also a good idea to avoid spaces in paths. Not sure if that can cause problems but I wouldn't be surprised.

Greetings,
Logged
allpowerful32
Jr. Member
**
Posts: 62


View Profile
« Reply #4 on: April 18, 2006, 11:12:09 pm »

Just put quotes around paths with spaces.
Logged
namiz
Newbie
*
Posts: 26


View Profile Email
« Reply #5 on: April 18, 2006, 11:23:24 pm »

Just put quotes around paths with spaces.

I don't really understand where i should put the quotes. Could you please clarify that.

Thanks,
Nate

EDIT: I just moved my crystal folder to C: and it seems to be working correctly hehe...
« Last Edit: April 18, 2006, 11:29:01 pm by namiz » Logged
namiz
Newbie
*
Posts: 26


View Profile Email
« Reply #6 on: April 18, 2006, 11:40:56 pm »

I have another error. I entered the following commands:

./configure
make -k all

and I recieved this error message:

$ ./configure make -k all
configure: WARNING: you should use --build, --host, --target
configure: error: unrecognized option: -k
Try `./configure --help' for more information.

Thanks,
Nate
Logged
jorrit
Administrator
Hero Member
*****
Posts: 1706


View Profile
« Reply #7 on: April 19, 2006, 05:08:17 am »

You should put them as seperate commands. i.e. first type ./configure and wait until that finishes.

Greetings,
Logged
namiz
Newbie
*
Posts: 26


View Profile Email
« Reply #8 on: April 19, 2006, 12:53:32 pm »

By just typing in ./configure i recieve the following error message:

$ ./configure
checking build system type... i686-pc-mingw32
checking host system type... i686-pc-mingw32
checking for gcc... no
checking for cc... no
checking for cc... no
checking for cl... no
configure: error: no acceptable C compiler found in $PATH
See `config.log' for more details.


I think its aking for a C compiler so how would i do this?
Logged
jorrit
Administrator
Hero Member
*****
Posts: 1706


View Profile
« Reply #9 on: April 19, 2006, 12:58:25 pm »

By just typing in ./configure i recieve the following error message:

$ ./configure
checking build system type... i686-pc-mingw32
checking host system type... i686-pc-mingw32
checking for gcc... no
checking for cc... no
checking for cc... no
checking for cl... no
configure: error: no acceptable C compiler found in $PATH
See `config.log' for more details.


I think its aking for a C compiler so how would i do this?

Your MingW and MSYS install is wrong it seems. Check that you did that ok. i.e. you must first install mingw and then  msys.

Greetings,
Logged
namiz
Newbie
*
Posts: 26


View Profile Email
« Reply #10 on: April 19, 2006, 01:08:26 pm »

Yes, i haven't installed MingW. You guys are so helpful.

thanks,
Nate
Logged
namiz
Newbie
*
Posts: 26


View Profile Email
« Reply #11 on: April 19, 2006, 02:36:55 pm »

Uh im confused again... i typed in ./configure and then stuff happened. Then i type make -k all and stff happened, and the last thing that happened was this:

  "\0"
}
__EOF__



    cat ./out/msysx86/optimize/plugins/video/cursor/cscursor_versionrc.rc ./out/msysx86/optimize/plugins/video/cursor/cscursor_metarc.rc | windres --use-temp-file  --include-dir=./out/msysx86/optimize/plugins/video/cursor --include-dir=./out/msysx86/optimize/plugins/video/cursor -o ./out/msysx86/optimize/plugins/video/cursor/cscursor_resource.o


    g++ -o cscursor.dll ./out/msysx86/optimize/plugins/video/cursor/cursor.o ./out/msysx86/optimize/plugins/video/cursor/cscursor_resource.o -L/C/CrystalSpaceLibs/lib -L/C/CrystalSpaceLibs/lib/mingw-gcc-3.2 -lm -L/usr/lib/w32api -lgdi32 -lshell32 -shared -mwindows ./out/msysx86/optimize/libs/libcrystalspace.a -lzlib -L/C/CrystalSpaceLibs/lib -L/C/CrystalSpaceLibs/lib/mingw-gcc-3.2 -lm -L/usr/lib/w32api -lgdi32 -lshell32


I know its not an error message, but what do i know now?
Logged
jorrit
Administrator
Hero Member
*****
Posts: 1706


View Profile
« Reply #12 on: April 19, 2006, 02:45:24 pm »

Hmm... I see no error message there. Why do you think it is an error?

Anyway perhaps you should try 'jam' instead of 'make'. It is better supported. Just type 'jam' instead of 'make -k all'.

Greetings,
Logged
namiz
Newbie
*
Posts: 26


View Profile Email
« Reply #13 on: April 19, 2006, 02:59:04 pm »

No i know it not an error message but that was the last thing that hppened then it just stopped and returned to the:

Owner@YOUR-4E0903614A /c/crystal/CS
$

I was wondering what do i do after the
 ./configure make -k all


EDIT: Okay, I used jam instead now what?
« Last Edit: April 19, 2006, 03:01:16 pm by namiz » Logged
jorrit
Administrator
Hero Member
*****
Posts: 1706


View Profile
« Reply #14 on: April 19, 2006, 03:01:57 pm »

Well if it is not an error then CS is compiled and you should be able to use it. i.e. run a few apps like isotest.exe and walktest.exe and see if they work.

Greetings,
Logged
Pages: [1] 2 3 Print 
« previous next »
Jump to:  

Powered by MySQL Powered by PHP Powered by SMF 1.1.2 | SMF © 2006-2007, Simple Machines LLC Valid XHTML 1.0! Valid CSS!
Page created in 5.506 seconds with 16 queries.