Crystal Space
Welcome, Guest. Please login or register.
September 19, 2014, 04:52:54 am

Login with username, password and session length
Search:     Advanced search
9018 Posts in 2051 Topics by 8481 Members
Latest Member: Cex18145xu
* Home Help Search Login Register
+  Crystal Space
|-+  Crystal Space Development
| |-+  Support
| | |-+  Errors running cell and crystalcore
« previous next »
Pages: [1] Print
Author Topic: Errors running cell and crystalcore  (Read 2367 times)
rpgcrazed
Newbie
*
Posts: 8


View Profile
« on: June 26, 2005, 01:24:08 am »

When tring to run CEL via "celtst celtestdemo.zip" i get the errors:
cel.persistence:  Error opening file 'level.xml'!
celtest:  Error loading level 'level.xml' at 'celtestdemo.zip'!

and when tring to run ./crystalcore
Start loading!

crystalspace.thingloader.parse:
  Bad UV coordinates for polygons in this thing!
[node:
  world,sector(name=Scene),meshobj(name=gccin_panel_holo),params]

crystalspace.maploader.parse.image:
  Could not open image file 'no' on VFS!

crystalspace.maploader.parse.texture:
  Couldn't load image 'no', using checkerboard instead!

crystalspace.engine.warning:
  Couldn't load cached lighting for 1 object(s):
      Cylinder.004
  Use -relight cmd option to refresh lighting.

crystalspace.pluginmgr.loadplugin:
  WARNING: could not load plugin
  'crystalspace.mesh.loader.factory.sprite.cal3d'
crystalspace.maploader.parse.meshfact:  Error loading plugin 'crystalspace.mesh.loader.factory.sprite.cal3d'!
[node: meshfact(name=rock_alien),plugin]
cel.pfmesh.loadmeshfactory:  Error loading mesh object factory or library 'Alien.cal3d'!
cel.propclass.mesh:  Can't load mesh 'rock_alien/Alien.cal3d' (path '/cc/models/rock_alien') for action LoadMeshPath!

crystalspace.thingloader.parse:
  Bad UV coordinates for polygons in this thing!
[node:
  world,sector(name=lab),meshobj(name=Cube.008),params]
  Bad UV coordinates for polygons in this thing!
[node:
  world,sector(name=lab),meshobj(name=Cube.016),params]
  Bad UV coordinates for polygons in this thing!
[node:
  world,sector(name=lab),meshobj(name=Cube.018),params]
  Bad UV coordinates for polygons in this thing!
[node:
  world,sector(name=lab),meshobj(name=Cube.051),params]
  Bad UV coordinates for polygons in this thing!
[node:
  world,sector(name=lab),meshobj(name=Cube.213),params]
  Bad UV coordinates for polygons in this thing!
[node:
  world,sector(name=lab),meshobj(name=Cube.214),params]
  Bad UV coordinates for polygons in this thing!
[node:
  world,sector(name=lab),meshobj(name=Cube.372),params]
  Bad UV coordinates for polygons in this thing!
[node:
  world,sector(name=lab),meshobj(name=Cube.373),params]
  Bad UV coordinates for polygons in this thing!
[node:
  world,sector(name=lab),meshobj(name=Cube.380),params]
  Bad UV coordinates for polygons in this thing!
[node:
  world,sector(name=lab),meshobj(name=Cube.382),params]
  Bad UV coordinates for polygons in this thing!
[node:
  world,sector(name=lab),meshobj(name=Cube.385),params]
  Bad UV coordinates for polygons in this thing!
[node:
  world,sector(name=lab),meshobj(name=Cube.387),params]
  Bad UV coordinates for polygons in this thing!
[node:
  world,sector(name=lab),meshobj(name=Cylinder.003),params]
  Bad UV coordinates for polygons in this thing!
[node:
  world,sector(name=lab),meshobj(name=Cylinder.014),params]
  Bad UV coordinates for polygons in this thing!
[node:
  world,sector(name=lab),meshobj(name=Cylinder.026),params]
  Bad UV coordinates for polygons in this thing!
[node:
  world,sector(name=lab),meshobj(name=Cylinder.029),params]
  Bad UV coordinates for polygons in this thing!
[node:
  world,sector(name=lab),meshobj(name=Cylinder.047),params]
  Bad UV coordinates for polygons in this thing!
[node:
  world,sector(name=lab),meshobj(name=Mesh.002),params]
  Bad UV coordinates for polygons in this thing!
[node:
  world,sector(name=lab),meshobj(name=Mesh.007),params]
  Bad UV coordinates for polygons in this thing!
[node:
  world,sector(name=lab),meshobj(name=Mesh.009),params]
  Bad UV coordinates for polygons in this thing!
[node:
  world,sector(name=lab),meshobj(name=Mesh),params]

crystalspace.engine.warning:
  Couldn't load cached lighting for 14 object(s):
      Cube.004
      Cube.377
      Cylinder.001
      Cylinder.002
      ...
  Use -relight cmd option to refresh lighting.
Stop loading!

crystalspace.pluginmgr.loadplugin:
  WARNING: could not load plugin
  'crystalspace.mesh.loader.factory.sprite.cal3d'
crystalspace.maploader.parse.meshfact:  Error loading plugin 'crystalspace.mesh.loader.factory.sprite.cal3d'!
[node: meshfact(name=male_player),plugin]
cel.pfmesh.loadmeshfactory:  Error loading mesh object factory or library 'male_player.cal3d'!
crystalcore:  Error loading model! You can download the models from:
http://www.crystalspace3d.org/support/crystalcore/
See instructions in README.TXT.
crystalcore:  Could not create our hero!

 I am building fresh from CVS on CS,cel and CrystalCore following the instructions here : http://www.crystalspace3d.org/tikiwiki/tiki-index.php?page=Crystal+Core+Running
Thanks all!
 evil
Logged
deckerego
Full Member
***
Posts: 149


View Profile WWW
« Reply #1 on: June 26, 2005, 07:46:38 pm »

Do you receive any errors when just running `celtst -relight`?
Logged
rpgcrazed
Newbie
*
Posts: 8


View Profile
« Reply #2 on: June 27, 2005, 07:53:21 am »

when using the command "celtst -relight" without the celtestdemo.zip i get

crystalspace.pluginmgr.loadplugin:
  WARNING: could not load plugin
  'crystalspace.mesh.loader.factory.sprite.cal3d'
crystalspace.maploader.parse.meshfact:  Error loading plugin 'crystalspace.mesh.loader.factory.sprite.cal3d'!
[node: library,meshfact(name=test),plugin]
cel.pfmesh.loadmeshfactory:  Error loading mesh object factory or library 'cally.cal3d'!
Load TYPE plugin crystalspace.mesh.object.haze
Print: Hello world!
Print: Hello world (small)!
Segmentation fault
Logged
deckerego
Full Member
***
Posts: 149


View Profile WWW
« Reply #3 on: June 27, 2005, 04:20:33 pm »

Ah - looks like you haven't built and installed cal3d yet. Have you been able to run CS' walktest yet?
Logged
rpgcrazed
Newbie
*
Posts: 8


View Profile
« Reply #4 on: June 28, 2005, 02:10:18 am »

I have cal3d built and installed actually.
yes, walktest runs fine.
downloaded fresh CVS code, going to compile and see what happens.
thx for your help Smiley
 evil
Logged
Pages: [1] Print 
« previous next »
Jump to:  

Powered by MySQL Powered by PHP Powered by SMF 1.1.2 | SMF © 2006-2007, Simple Machines LLC Valid XHTML 1.0! Valid CSS!
Page created in 3.208 seconds with 15 queries.