Crystal Space
Welcome, Guest. Please login or register.
November 18, 2017, 01:14:01 pm

Login with username, password and session length
Search:     Advanced search
9081 Posts in 2051 Topics by 80387 Members
Latest Member: Jorgecrook2872
* Home Help Search Login Register
+  Crystal Space
|-+  Crystal Space Development
| |-+  Support
| | |-+  AttributeError: 'NoneType' object has no attribute 'appendChild'
« previous next »
Pages: [1] Print
Author Topic: AttributeError: 'NoneType' object has no attribute 'appendChild'  (Read 7455 times)
Posts: 4

View Profile Email
« on: July 04, 2008, 04:41:10 pm »

OK! So, I previously had a problem with setting Crystal, CEL and B2CS to work and was (kind of) forced to change OS for another reason... This actually solved my previous problem. Now, I have one problem left and an annoying thing to solve:

The problem:

when I use the basic blender scene (a lamp, a cube and a camera) and set the cube as the "player" in the gui (otherwise I get a no player error while using CEL export), I get this thread's title's error, or, (much) more precisely:

Done: /tmp/ created
I: Total Export Time: 0h 0m 0s
I: Starting Library Export to /tmp/
I: Exporting sector: Scene
Exporting PLAYER:Cube None
 * fast genmesh export no uv
Traceback (most recent call last):
  File "/home/jeremie/.blender/scripts/bpymodules/b2cs/gui/", line 10, in button_event
  File "/home/jeremie/.blender/scripts/bpymodules/b2cs/gui/", line 52, in button_event
  File "/home/jeremie/.blender/scripts/bpymodules/b2cs/gui/", line 316, in button_event
  File "/home/jeremie/.blender/scripts/bpymodules/b2cs/export/", line 536, in doExportWorld
    res = export_blend(filename,wf,do_view,run)
  File "/home/jeremie/.blender/scripts/bpymodules/b2cs/export/", line 374, in export_blend
    if not export_world(run):
  File "/home/jeremie/.blender/scripts/bpymodules/b2cs/export/", line 208, in export_world
  File "/home/jeremie/.blender/scripts/bpymodules/b2cs/export/", line 141, in export_sector
  File "/home/jeremie/.blender/scripts/bpymodules/b2cs/", line 474, in export_object
  File "/home/jeremie/.blender/scripts/bpymodules/b2cs/", line 252, in sub_export
  File "/home/jeremie/.blender/scripts/bpymodules/b2cs/", line 213, in sub_run_function
  File "/home/jeremie/.blender/scripts/bpymodules/b2cs/export/", line 956, in export
  File "/home/jeremie/.blender/scripts/bpymodules/b2cs/export/", line 489, in export_mesh
    node_entity = celxml.cel_add_entity(node_sector,"camera",basetpl)
  File "/home/jeremie/.blender/scripts/bpymodules/b2cs/", line 101, in cel_add_entity
    node = xml_add_child(sector_node,"addon")
  File "/home/jeremie/.blender/scripts/bpymodules/b2cs/", line 79, in xml_add_child
    node = parentnode.appendChild(document.createElementNS(None,element))
AttributeError: 'NoneType' object has no attribute 'appendChild'

and if I don't use the CEL export option:

FtWarning: Creation of InputSource without a URI
/home/jeremie/Desktop/folders/CEL/celstart: error while loading shared libraries: cannot open shared object file: No such file or directory
start detecting experimental features
Check for b2cs3d dependencies:
 * embedgl True
 * cspace False
 * pycscegui False
 * newbinds False
 * verse False
 * blcelc module not found
Check for obsidian dependencies:
 * celstart /home/jeremie/Desktop/folders/CEL/celstart
 * pycegui False
Using following experimental extensions:
end detecting experimental features
Read 52 pcclasses info.
Initializing blender2crystal core
Loading submodules in
Loading submodules in ui
Loading submodules in tool
Loading submodules in export
Loading submodules in import
Done: Blender2Crystal succesfully loaded
Quest: TimedDeath
 * state init
    * attr: timeout $timeout
  * trigger timeout
   * reward destroyentity
    * attr: entity $this
 * Load default timeout 10000
timeout 10000
E: trying to use viewmesh export mode. Failed to find the viewmesh program.

and indeed, I have no viewmesh program for some reason - though that shouldn't be the problem of the CEL export error.

Now, the thing that's annoying me, aside from that, is that seemingly, I have to re set my CRYSTAL and CEL variables at each program exit...

Now, it's been weeks since I tried to make CS+CEL+B2CS(+Blender) work and it still doesn't so any help is mucho appreciated

Many thanks in advance - (please respond)

EDIT: Forgot again ><
OS: Ubuntu Hardy Heron (8.04)
CS version: latest trunk as of july 13, 2008
CEL version: latest trunk as of july 13, 2008
B2CS version: (guess what) latest trunk as of july 13, 2008

B2CS, CEL and CS come from SVN.

Blender version: 2.46 apricot rev. 15606 (debug version - current latest build on graphicall excluding the broken link one (rev15608))

That should do... again: any help is much appreciated.
« Last Edit: August 28, 2008, 07:33:13 pm by Blendercrystaled » Logged
Posts: 4

View Profile Email
« Reply #1 on: August 26, 2008, 10:20:16 pm »

Ok... Additional information:
1) I STILL need help
2) Walktest functions more or less (no particles after -relight and weird drawing on screen, but it seemingly is because of my graphic card (intel gma i945 gm)

Thanks to anyone who dare to try and help me.
Posts: 32

View Profile Email
« Reply #2 on: August 27, 2008, 08:44:40 pm »

After unzipping CS did you unzip the included .zip files?   If so, try pasting the unzipped .zip files in the folder you use to initiate walktest.

Hope that helps

Dutch (another newbie!)
Posts: 27

View Profile Email
« Reply #3 on: August 27, 2008, 09:38:20 pm »

Crystal Space VFS plugin handles zip folders without any problem.
Posts: 4

View Profile Email
« Reply #4 on: August 28, 2008, 07:32:00 pm »

Oops, I forgot to specify I got my version from SVN (other methods give me a black, empty room in walktest and throw lots of errors at me) (therefore, no .zip files except for some zip'd jpeg files in archives such as,, etc.) I'm going to edit this information.

Either way, my problem lies in the B2CS scripts and keep in mind that before using -relight, the "special effects" were there. I still tried to unzip the files in the Walktest directory but it did not change anything (I reused -relight to make sure, as well, without much success). I then repacked the files and put them where they were at first.

Thanks for your replies.
« Last Edit: August 29, 2008, 09:54:44 pm by Blendercrystaled » Logged
Full Member
Posts: 191

View Profile WWW
« Reply #5 on: August 31, 2008, 07:32:20 pm »

and indeed, I have no viewmesh program for some reason

Just a note, for viewmesh to get built, you need CEGUI 0.5 library (with development stuff).
If you happen to install it, just running ./configure again, then jam should build just what requires CEGUI.
As for the b2cs error, you should try to get Pablo (aka. caedes) either on IRC or by writing to CS or CEL mailing list...
Posts: 4

View Profile Email
« Reply #6 on: September 01, 2008, 01:35:23 pm »

Thanks. I'll try that and come back with my results. However, I already have libcegui-mk2-1 (v0.5.0-2) and libcegui-mk2-dev (v0.5.0-2 as well).
« Last Edit: September 01, 2008, 10:09:52 pm by Blendercrystaled » Logged
Pages: [1] Print 
« previous next »
Jump to:  

Powered by MySQL Powered by PHP Powered by SMF 1.1.2 | SMF © 2006-2007, Simple Machines LLC Valid XHTML 1.0! Valid CSS!
Page created in 6.206 seconds with 15 queries.