Crystal Space
Welcome, Guest. Please login or register.
November 27, 2014, 10:05:10 pm

Login with username, password and session length
Search:     Advanced search
9026 Posts in 2046 Topics by 9147 Members
Latest Member: Nikitaen
* Home Help Search Login Register
+  Crystal Space
|-+  Associate Projects
| |-+  CEL Discussion
| | |-+  CEL compiling problems... Again...
« previous next »
Pages: [1] Print
Author Topic: CEL compiling problems... Again...  (Read 6291 times)
Lavos
Newbie
*
Posts: 4


View Profile
« on: August 18, 2008, 01:14:05 pm »

I just can't compile CEL. It keeps returning the message:
"checking if Crystal Space SDK is usable... no
configure: error:
*** Crystal Space could not be found or was unusable. The latest version is
*** always available from http://www.crystalspace3d.org/
*** Also, be sure that you have either installed Crystal Space or set the
*** CRYSTAL environment variable properly."
The troubleshooting I've tried so far:
1.) I HAVE set the CRYSTAL environment variable
2.) I've tried to rename the folder(changing the EV accordingly)
3.) I've recompiled CS.
Neither of these worked. I have just formatted my HD, and before formatting I used to have CS and CEL compiled, with no problems at all!
I am using Windows as the OS and MinGW to compile.

Edit: I have solved the problem by asking somewhere else in the forum. Thank you for your help.
« Last Edit: August 20, 2008, 08:45:49 pm by Lavos » Logged
Newton64
Newbie
*
Posts: 21


View Profile Email
« Reply #1 on: August 22, 2008, 01:37:13 am »

Can you link to the solution, just for completeness?
Logged
Samir
Newbie
*
Posts: 2


View Profile Email
« Reply #2 on: September 18, 2008, 08:28:36 am »

Hi,
the solution to Lavos' question can be found at the following thread:
http://www.crystalspace3d.org/forum/index.php/topic,1696.0.html

However I'm having the very same problem but I do have CRYSTAL env var
properly set in MSYS (it's /c/CS3D/cs). Any suggestion on what can happen?
I attach the config.log file, I'm running XP SP2, CS/CEL 1.2.1 downloaded
from SF, MINGW/MSYS.

Thank you!

* config.log.txt (51.1 KB - downloaded 706 times.)
Logged
Samir
Newbie
*
Posts: 2


View Profile Email
« Reply #3 on: September 19, 2008, 12:25:15 pm »

Finally solved the problem. The solution was this: to compile both CS and CEL in
their respective source directories. Hope this may help someone.
 
Logged
attila
Guest
« Reply #4 on: October 20, 2008, 10:16:41 am »

I get the same error in Ubuntu 8.04.1

When building to a directory outside of the source directory:
Code:
cd /home/me/csbuild
../crystalspace-src-1.2.1/configuration
sudo jam
sudo jam install
sudo jam distclean

It does not help to do
Code:
export CRYSTAL=/home/me/crystalspace-src-1.2.1:/home/me/csbuild

I'm now doing a compile inside the source directory, instead of outside.. will update how it goes.

In the meantime any suggestions are greatly appreciated!
Logged
Pragma
Newbie
*
Posts: 6


View Profile Email
« Reply #5 on: October 24, 2008, 09:42:51 pm »

Hi!

I ran into some of these "be sure that you have either installed Crystal Space or set the CRYSTAL environment variable properly" issues, too.

Here you can see my env. variables to fix it:

CRYSTAL
Code:
<path to CS sdk>/crystalsdk:<path to CS sdk>/crystalsdk/lib/crystalspace-1.4:<path to CS sdk>/crystalsdk/etc/crystalspace-1.4

LD_LIBRARY_PATH
Code:
<path to CS sdk>/crystalsdk/lib:<path to CEL sdk>/cel/cel-sdk/lib

To compile CEL you need:
Code:
# so configure can find cs-config
export PATH="$PATH:<path to CS sdk>/crystalsdk"
# the linker needs this to link against CS
export LD_RUN_PATH="<path to CS sdk>/crystalsdk/lib"

If this don't work check if you have set CRYSTAL_X_Y and unset it. Check cs-config --libs and cs-config --libdir if it returns correct values. If not "be sure that you have either installed Crystal Space or set the CRYSTAL environment variable properly" Wink.

I wrote some scripts to automaticly checkout/configure/compile/build-sdk for cs and cel. Sombody intrested?

PS: You need this setup only if u dont want to be root to install/use cs and cel. I do this to not "contaminate" my system with configure install.

Best regards
Daniel
Logged
Neoberserker
Newbie
*
Posts: 7



View Profile WWW Email
« Reply #6 on: January 29, 2009, 10:13:59 am »

i wrote a script that tests the environment and downloads/compiles cel with ode.

Maybe that helps you:
http://www.crystalspace3d.org/forum/index.php/topic,1745.msg8145.html#msg8145
Logged

---------------------------------------
Linux, CG and photographie
http://www.neoBerserker.de
Pages: [1] Print 
« previous next »
Jump to:  

Powered by MySQL Powered by PHP Powered by SMF 1.1.2 | SMF © 2006-2007, Simple Machines LLC Valid XHTML 1.0! Valid CSS!
Page created in 8.318 seconds with 15 queries.