Crystal Space
Welcome, Guest. Please login or register.
April 23, 2014, 07:58:04 pm

Login with username, password and session length
Search:     Advanced search
8990 Posts in 2037 Topics by 7618 Members
Latest Member: Tymqwaro
* Home Help Search Login Register
+  Crystal Space
|-+  Crystal Space Development
| |-+  Support
| | |-+  [SOLVED] Tutorial compilation problem.
« previous next »
Pages: [1] Print
Author Topic: [SOLVED] Tutorial compilation problem.  (Read 1330 times)
yezu
Newbie
*
Posts: 1


View Profile Email
« on: February 02, 2009, 02:23:24 pm »

Hi!
I just recently figured it would be nice to fiddle with Crystal Space, so I have began to set my environment.
I run a Fedora 10 box, so everything was in the repository, including the external libs.

I've set up a environment in Eclipse according to this post:
http://www.crystalspace3d.org/forum/index.php/topic,850.0.html

The simple1.cpp from the /apps/tutorials/ built and ran nicely. However when I tried to built
and run the tutorial from the doc:
http://www.crystalspace3d.org/docs/online/manual/Simple-Header-File.html

I get en error:
‘iRenderManager’ was not declared in this scope
template argument 1 is invalid

which reference to line:
Code:
csRef<iRenderManager> rm;

Can anybody tell what I might have done wrong?
Or suggest some kind of a solution so I can go on with the tutorials?

Thanks for help Smiley

EDIT:
After some more looking I found out what was wrong.
Apparently the Crystal Space version on Fedora's repo is 1.2, while the doc's is 1.9
Simple Tongue
« Last Edit: February 02, 2009, 03:18:40 pm by yezu » Logged
Pages: [1] Print 
« previous next »
Jump to:  

Powered by MySQL Powered by PHP Powered by SMF 1.1.2 | SMF © 2006-2007, Simple Machines LLC Valid XHTML 1.0! Valid CSS!
Page created in 4.236 seconds with 15 queries.