Crystal Space
Welcome, Guest. Please login or register.
November 26, 2014, 05:13:31 am

Login with username, password and session length
Search:     Advanced search
9026 Posts in 2046 Topics by 9130 Members
Latest Member: Eddiehunter
* Home Help Search Login Register
+  Crystal Space
|-+  Crystal Space Development
| |-+  Support
| | |-+  Missing libraries at runtime
« previous next »
Pages: [1] Print
Author Topic: Missing libraries at runtime  (Read 1288 times)
Groogy
Newbie
*
Posts: 2


View Profile Email
« on: March 15, 2009, 12:39:26 pm »

Yo!

I'm just trying out Crystalspace but I really like the plugin-design that I've seen so far... Though it's giving me a headache...
It tells me that it can't find some libraries when trying to run it though it can still run without a problem? Walktest complains about a bunch of them though when running simple1 it complains only about one, so I though we could start there.

The missing one on simple1 is libfreetype2-cs.dll and when checking in all folders where Path points at I can't find it... Though I have libfreetype-6 in system32. So I got the freetype library... But judging from the name of the library it's the Crystalspace specific plugin of libfreetype2 right? How do I get a hold of that? Shouldn't it compile with it?

**EDIT**
Also thought it was worth mentioning that I have used the win32 binary executable to get all required libraries.
And I'm using MinGW with CodeBlocks(Not the CodeBlocks version installed with MinGW).


***EDIT Again***
I think I "fixed" it by not using "jam install". Now the demos work perfectly though it's hard to get it to work with my IDE. I fixed so it finds the static library to link with and the include files. But I am having a hard time setting up so that when I run it directly from Windows and not MSYS to get it to find the plugins. It is constantly trying to search in the same folder as the EXE file while I want it to NOT do that. Also if I run it trough Windows directly it complains about missing libz. But not in MSYS where everything works perfectly.

***LAST EDIT***(hopefully)
I think I fixed it completely now! never mind. If anyone has a similar problem they can contact me.
The thing was that the win32lib didn't place the DLLs where it was supposed to be. It has been fixed now and works for me.
« Last Edit: March 15, 2009, 05:33:38 pm by Groogy » Logged
Pages: [1] Print 
« previous next »
Jump to:  

Powered by MySQL Powered by PHP Powered by SMF 1.1.2 | SMF © 2006-2007, Simple Machines LLC Valid XHTML 1.0! Valid CSS!
Page created in 4.235 seconds with 15 queries.