Crystal Space
Welcome, Guest. Please login or register.
September 02, 2014, 11:34:58 pm

Login with username, password and session length
Search:     Advanced search
9009 Posts in 2043 Topics by 8379 Members
Latest Member: Hamlock3
* Home Help Search Login Register
+  Crystal Space
|-+  Crystal Space Development
| |-+  Support
| | |-+  Problems installing Blender2Crystal
« previous next »
Pages: [1] Print
Author Topic: Problems installing Blender2Crystal  (Read 1179 times)
Arcainone
Newbie
*
Posts: 3


View Profile Email
« on: July 04, 2010, 07:46:53 am »

This has been a very frustrating experience trying to get anything python working together on my computer, but that is an entirely different Rant.  My problem is this.

I have Blender 2.4.9 which is compiled with Python 2.6.2
I am running a x64 windows 7 ultimate OS so Python 2.6.2 is x64 bit version.
PIL only has 32 bit installers, but there is an x64 bit installer.
PyXML only has 32 bit installers, had to compile it myself (Unfortunatly I do not know Python well) and only guess I have done it correctly.

In my 64bit Blender I get NameError: global name 'Domlette' is not defined

in my 32 bit Blender I get ImportError: No module named tempfile (which exists in my 2.6 Libs directory)

Has anyone been able to get this working on their Windows x64 bit system?
Logged
Scorc
Newbie
*
Posts: 4


View Profile Email
« Reply #1 on: July 08, 2010, 12:15:29 pm »

Blender2Crystal doesn't work out-of-the-box with Python 2.6 and Blender 2.49b even on WinXP Sad Had to patch a few lines myself (I was lucky). First it was of some python library (win32 release version damn buggy), then B2C's bug. Try installing the latest versions from source
Logged
Arcainone
Newbie
*
Posts: 3


View Profile Email
« Reply #2 on: July 12, 2010, 07:39:02 am »

Blender2Crystal doesn't work out-of-the-box with Python 2.6 and Blender 2.49b even on WinXP Sad Had to patch a few lines myself (I was lucky). First it was of some python library (win32 release version damn buggy), then B2C's bug. Try installing the latest versions from source

Thanks for responding, maybe you can help.  I have downloaded the source versions of both PyXML 0.8.4 and PIL 1.1.7.  Because I have Crystal Space I have the jpg, tga, png, and zlib libraries installed and in their own special directory.  I can compile PyXML  using the lines:

"python setup.py build --with-xslt --with-xpath"
"python setup.py install --with-xslt --with-xpath"

I am not sure if I need the directives on the install but I add them anyway. However, none of the demos are able to run because I beleive they are outdated.  They request a file called core in the xml.dom directory, but core.py does not exist in the xml.dom directory.  There is a minidom.py file but no core.py.  So I am unsure if it is installed correctly because outside first learning python, then writing a test script I am unable to test it...

to compile the PIL files seem to be even more difficult.  As noted I have the image libraries installed on a seperate hard drive.  Where Python is c:/Python26, the C++ libraries would be located on D:/CrystalSpace/CrystalSpace_Libraries/(Libs or includes)/
The instructions tell you to specify a tuple directory for these libraries so I give it "D:/dir/lib","D:/dir/includes".  Then using setup.py similar to the above, I test it with as directed in the README, again it seems to fail...

And I have no idea what the B2C but is...
Logged
Pages: [1] Print 
« previous next »
Jump to:  

Powered by MySQL Powered by PHP Powered by SMF 1.1.2 | SMF © 2006-2007, Simple Machines LLC Valid XHTML 1.0! Valid CSS!
Page created in 8.311 seconds with 17 queries.