Crystal Space
Welcome, Guest. Please login or register.
September 02, 2014, 08:16:04 am

Login with username, password and session length
Search:     Advanced search
9009 Posts in 2043 Topics by 8374 Members
Latest Member: Donaldyokley
* Home Help Search Login Register
+  Crystal Space
|-+  Crystal Space Development
| |-+  Support
| | |-+  csjava.dll wanted | linker problem (?)
« previous next »
Pages: [1] Print
Author Topic: csjava.dll wanted | linker problem (?)  (Read 1735 times)
Sp4M
Newbie
*
Posts: 8


View Profile Email
« on: December 20, 2010, 01:32:47 am »

Hi,

I tried to generate csjava.dll (I would use CS in java on windows).
I built CS on linux with configure/jam, everything is now ok (0 error) and I get the crystalspace.jar
I built CS on windows with VS Express C++ 2008 with msvc9 solution, everything build (0 error)
but still no trace of csjava.dll ...

Project (SimpleRoom) run on Eclipse (with .jar linked) gives :

Code:
Loading CrystalSpace library
Fatal Error: unresolved symbol in 'csjava'.
java.lang.UnsatisfiedLinkError: no csjava in java.library.path

- Version of CS : 1.4.0
- Version of winlibs package : cs-win32libs-1.4_002
- Operating system : Win7
- Compiler : VS Express 2008


Any idea ?
« Last Edit: December 26, 2010, 05:50:44 am by Sp4M » Logged
duodenum
Newbie
*
Posts: 1


View Profile WWW Email
« Reply #1 on: December 20, 2010, 01:39:34 pm »

Can you place your all code here. I will try it on my com & fixit for you.
Logged

Sp4M
Newbie
*
Posts: 8


View Profile Email
« Reply #2 on: December 20, 2010, 02:13:36 pm »

I didn't really generated many code for now, it doesn't work at the beginning with this :
(SimpleRoom.java is unchanged code from CS)

Code:
public class Main {
public static void main(String[] args) {
new SimpleRoom();
}
}

I think the problem is from Eclipse configuration for CS. Again, I don't have any csjava.dll ...
« Last Edit: December 20, 2010, 08:53:36 pm by Sp4M » Logged
Sp4M
Newbie
*
Posts: 8


View Profile Email
« Reply #3 on: December 26, 2010, 02:07:17 am »

am I the only one to use cystalspace on windows with java ... ? Sad
Logged
Sp4M
Newbie
*
Posts: 8


View Profile Email
« Reply #4 on: December 26, 2010, 05:47:11 am »

I probably found a part of the solution by myself. (my problem is still to obtain csjava.dll file)

when I run the configure script, it gives me
Code:
...
checking if --kill-at is accepted... no
...

But configure file says
Quote
Check if linker recognizes --kill-at which is needed to make csjava.dll


after investigations in config.log, we can read
Code:
configure:18376: checking if --kill-at is accepted
configure:18477: g++ -o conftest     -Wl,--kill-at   conftest.cpp   -lnsl -lc  >&5
/usr/bin/ld: unrecognized option '--kill-at'
/usr/bin/ld: use the --help option for usage information

in fact, the /usr/bin/ld command does not actualy recognize the --kill-at, but the /usr/i586-mingw32msvc/bin/ld does.
But how tell the g++ to check the "correct" linker here ?
« Last Edit: December 26, 2010, 05:51:12 am by Sp4M » Logged
Sp4M
Newbie
*
Posts: 8


View Profile Email
« Reply #5 on: December 28, 2010, 12:23:46 am »

(No i'm not flooding !)

Update : in fact the default linker does recognize the --kill-at option, but :
Quote from: man ld
   --kill-at
           If  given, the stdcall suffixes (@nn) will be stripped from symbols
           before they are exported.  [This option is specific to the i386  PE
           targeted port of the linker]

and

Code:
uname -m
gives
Quote
i686

could be a problem there, isn't it ?
Logged
kickvb
Global Moderator
Jr. Member
*****
Posts: 79


View Profile
« Reply #6 on: December 29, 2010, 04:20:06 pm »

Sorry, I'm not able to help you.
But maybe you would try asking your question on the mailing list or the irc, the developers that can probably answer to this are more active on these communication channels.
Logged
Pages: [1] Print 
« previous next »
Jump to:  

Powered by MySQL Powered by PHP Powered by SMF 1.1.2 | SMF © 2006-2007, Simple Machines LLC Valid XHTML 1.0! Valid CSS!
Page created in 4.248 seconds with 16 queries.