Crystal Space
Welcome, Guest. Please login or register.
April 23, 2014, 11:31:41 pm

Login with username, password and session length
Search:     Advanced search
8990 Posts in 2037 Topics by 7618 Members
Latest Member: Tymqwaro
* Home Help Search Login Register
+  Crystal Space
|-+  Crystal Space Development
| |-+  Support
| | |-+  Can't compile CS...slowly going insane...
« previous next »
Pages: [1] Print
Author Topic: Can't compile CS...slowly going insane...  (Read 1192 times)
Gmilo
Newbie
*
Posts: 2


View Profile Email
« on: June 26, 2012, 01:38:46 am »

Several days ago, I chose CS for a possible game engine...I've read the tutorial (several times), downloaded CS version 1.4.1 and CEL, and using MSVC 10 cannot get past the build.  (191 fail, 0 successful). 

I added INCLUDE and LIB environmental variables and moved win32libs folder to the CS folder (resolving apparently all of the header file not found errors.  My latest build attempt resulted in many of the projects now having obj files, log files, manifests and pdb files...but no dll files.

Trying to read the output file (which is overwhelmingly compicated - thx MS) leads me to believe that it is a problem within MSVC, a possible clue being in the Micrsoft.CppCommon.Targets XML code, in the PostBuildEvent, that fails when it cannot find the (nonexistant) dll that should have been created.
Example:
1>C:\Program Files (x86)\MSBuild\Microsoft.Cpp\v4.0\Microsoft.CppCommon.targets(113,5): error MSB3073: copy /y "C:\CS\mk\msvc9\..\..\out\release9\build\libcrystalspace\libcrystalspace.dll" ..\..\out\release9\bin\

Why the dlls are not being created is a mystery to me.

Using:
Windows Vist Home Premium, SP 2
Gateway PC Intel Core i7 CPU 950 @ 3.07 GHz 9 GB RAM 64-bit OS
MS Visual C++ 2010 Express, Version 10.0.40219.1 SP1

Logged
jorrit
Administrator
Hero Member
*****
Posts: 1704


View Profile
« Reply #1 on: June 26, 2012, 04:49:07 am »

Hmm, I'm not experienced with MSVC but can you give a bit more information? For example, which version of CS, which version of cswinlibs and so on. And also a log of the computer output.

Greetings,
Logged
res
Develazyoper
CS Developer
Full Member
*****
Posts: 206


View Profile Email
« Reply #2 on: June 26, 2012, 07:09:48 am »

Building CS 1.4 (or CEL 1.4) with MSVC 2010 is not supported. You need to either get an older VC version (IIRC you can still download Visual C++ Express 2008, which is fine) or a newer CS/CEL version (2.0 works well with VC 2010).
Logged
jorrit
Administrator
Hero Member
*****
Posts: 1704


View Profile
« Reply #3 on: June 26, 2012, 07:21:36 am »

I strongly recommend using 2.0 of CS btw. 1.4 is very old and 2.0beta3 is really rather stable.

Greetings,
Logged
Gmilo
Newbie
*
Posts: 2


View Profile Email
« Reply #4 on: June 29, 2012, 11:40:35 pm »

OK, thanks for all the help.  I could only get up to 18 projects to build successfully, all the rest failed.  This was using the beta (2.0) version, and trying every option available (C++ 8, 9, 10, win32, 64, yada, yada.)  Took quite a while, but that's it for me.  I'm moving on to another engine.  I may be back someday, we'll see.
Logged
Pages: [1] Print 
« previous next »
Jump to:  

Powered by MySQL Powered by PHP Powered by SMF 1.1.2 | SMF © 2006-2007, Simple Machines LLC Valid XHTML 1.0! Valid CSS!
Page created in 8.305 seconds with 17 queries.