Crystal Space
Welcome, Guest. Please login or register.
August 30, 2014, 09:28:41 am

Login with username, password and session length
Search:     Advanced search
9009 Posts in 2043 Topics by 8363 Members
Latest Member: Yurikalee6
* Home Help Search Login Register
+  Crystal Space
|-+  Crystal Space Development
| |-+  Support
| | |-+  Drawing a picture for HUD?
« previous next »
Pages: [1] Print
Author Topic: Drawing a picture for HUD?  (Read 3284 times)
Chrono
Newbie
*
Posts: 1


View Profile Email
« on: September 21, 2005, 03:16:40 am »

hi i not new in c++ but in Crystal Space i am
so fast and painless

how do i draw simple jgp o bmp files  in crystal space
for a HUD in a FPS
or how do i load the crystal space logo in tutorial 1 aka simple 1
also is there any simpler tutorials for cel some where the ones that are in
the cvs or pseduo are well no very simple or not that well doc as a noob hope je je
thanks for the help

*admin: changed the topic to something more descriptive from "noob help"*
« Last Edit: December 07, 2005, 04:39:21 pm by dingobloo » Logged
jorrit
Administrator
Hero Member
*****
Posts: 1706


View Profile
« Reply #1 on: September 21, 2005, 07:18:12 am »

hi i not new in c++ but in Crystal Space i am
so fast and painless

how do i draw simple jgp o bmp files  in crystal space
for a HUD in a FPS
or how do i load the crystal space logo in tutorial 1 aka simple 1
also is there any simpler tutorials for cel some where the ones that are in
the cvs or pseduo are well no very simple or not that well doc as a noob hope je je
thanks for the help


How to draw simple images in documented in the manual. Check the using Crystal Space chapter. More specifically you may find section 4.22.2 interesting.

Did you check out the tutorial you can download from the main CS site in the CEL section?

Greetings,
Logged
kornerr
Full Member
***
Posts: 101


347968356
View Profile WWW Email
« Reply #2 on: December 06, 2005, 06:43:03 pm »

While using Simple1 compiled during installation.

Why when I use "-mode=800x600 -fs" or "-mode=640x480 -fs" the screen has only ~75Hz, not 85Hz or higher?
Also with "-mode" used I get the following error:
Code:
X Error of failed request:  BadWindow (invalid Window parameter)
  Major opcode of failed request:  4 (X_DestroyWindow)
  Resource id in failed request:  0x2a00004
  Serial number of failed request:  279
  Current serial number in output stream:  281

Thanks.
Logged

[SOM]Roberto
Jr. Member
**
Posts: 79


View Profile Email
« Reply #3 on: December 23, 2005, 08:43:11 pm »

Now this tutor is in 5.8.11 in online doc...

 5.8.11 Loading Images for Pixmaps

New version in:  4.23.2 Loading Images for Pixmaps
« Last Edit: December 24, 2005, 04:00:57 pm by [SOM]Roberto » Logged
[SOM]Roberto
Jr. Member
**
Posts: 79


View Profile Email
« Reply #4 on: December 24, 2005, 04:16:06 pm »

Now I making scene viewer program first. I using mouse camera rotating and keys moving.
If I making only "csRef<iImageIO> imgldr;" code in header file, mouse rotate stopping. Why?

/Well, I maked "csRef<iFont> font;" this error again. I rewrote this line "csRef<iFont> fnt;" &
the error stopped./

If I rewrite this line "csRef<iImageIO> my_images;" and etc error again. Sad

I steal the mouse rotating from water demo.

I using 15-Dec-2005 CS from CVS & 4.23.2 Loading Images for Pixmaps documentation.
« Last Edit: December 24, 2005, 04:26:01 pm by [SOM]Roberto » Logged
jorrit
Administrator
Hero Member
*****
Posts: 1706


View Profile
« Reply #5 on: December 26, 2005, 03:02:24 pm »

Now I making scene viewer program first. I using mouse camera rotating and keys moving.
If I making only "csRef<iImageIO> imgldr;" code in header file, mouse rotate stopping. Why?

/Well, I maked "csRef<iFont> font;" this error again. I rewrote this line "csRef<iFont> fnt;" &
the error stopped./

If I rewrite this line "csRef<iImageIO> my_images;" and etc error again. Sad

I steal the mouse rotating from water demo.

I using 15-Dec-2005 CS from CVS & 4.23.2 Loading Images for Pixmaps documentation.

This is not enough information to help you. I need to see the full program and also what exactly goes wrong.

Greetings,
Logged
[SOM]Roberto
Jr. Member
**
Posts: 79


View Profile Email
« Reply #6 on: December 26, 2005, 11:49:48 pm »

My program: http://rafb.net/paste/results/ox9oIg24.html
Logged
jorrit
Administrator
Hero Member
*****
Posts: 1706


View Profile
« Reply #7 on: December 27, 2005, 07:56:01 am »


Well that's very weird. Adding a csRef cannot cause something to stop working. I have no idea what is wrong. Sorry.

Greetings,
Logged
[SOM]Roberto
Jr. Member
**
Posts: 79


View Profile Email
« Reply #8 on: December 27, 2005, 05:35:31 pm »

OK. I try working on viewer all things. I will write the solution. Smiley
Logged
[SOM]Roberto
Jr. Member
**
Posts: 79


View Profile Email
« Reply #9 on: March 18, 2006, 02:17:28 am »

Well I founded nice CS tutorials:
http://www.stud.uni-karlsruhe.de/~uxsm/roborun/roborun.html#gameidea
http://www.geocities.com/sunshadowgames/cs_tut.html

There is Cs pixmap too. Smiley
I using tga alpha pixmap picture in my hud because CEGUI is slower.
Logged
Pages: [1] Print 
« previous next »
Jump to:  

Powered by MySQL Powered by PHP Powered by SMF 1.1.2 | SMF © 2006-2007, Simple Machines LLC Valid XHTML 1.0! Valid CSS!
Page created in 7.218 seconds with 16 queries.