Crystal Space
Welcome, Guest. Please login or register.
July 29, 2014, 06:22:46 pm

Login with username, password and session length
Search:     Advanced search
9005 Posts in 2043 Topics by 8254 Members
Latest Member: Natashascott
* Home Help Search Login Register
+  Crystal Space
|-+  Crystal Space Development
| |-+  General Crystal Space Discussion
| | |-+  Only using shadows for some meshes
« previous next »
Pages: [1] Print
Author Topic: Only using shadows for some meshes  (Read 2794 times)
Jonathan
Guest


Email
« on: January 30, 2006, 06:57:46 am »

I am trying to get shadows to work on some of the simpler meshes, but not the more detailed ones because it is killing performance. In my world file I am using std_rloop_shadowed. I am trying to disable shadows on meshes using

SetShadowCasting(false) and SetShadowReceiving(false). The shadows still appear for some reason.

I am using the pseudo stable release from 27-01-06 but have tried 3 other CVS versions in the last month. Libs are cs-win32libs-0.99r0_018. Video card is Nvidia 6600GT, drivers are 81.98, OS is win2K.

And also that renderloop runs even slower on the pseudo stable release then it did in the CVS versions.

Jonathan
Logged
jorrit
Administrator
Hero Member
*****
Posts: 1706


View Profile
« Reply #1 on: January 30, 2006, 08:52:40 am »

I am trying to get shadows to work on some of the simpler meshes, but not the more detailed ones because it is killing performance. In my world file I am using std_rloop_shadowed. I am trying to disable shadows on meshes using

SetShadowCasting(false) and SetShadowReceiving(false). The shadows still appear for some reason.

I am using the pseudo stable release from 27-01-06 but have tried 3 other CVS versions in the last month. Libs are cs-win32libs-0.99r0_018. Video card is Nvidia 6600GT, drivers are 81.98, OS is win2K.

And also that renderloop runs even slower on the pseudo stable release then it did in the CVS versions.

Jonathan

First the pseudo-stable is equal to the CVS version (at this moment) so I'm not sure what you mean by that.

The only way to disable shadows for high poly object is to add this construct to the meshobj definition:

Code:
<polymesh>
  <shadow/>
</polymesh>

Greetings,


Logged
Jonathan
Guest


Email
« Reply #2 on: January 30, 2006, 12:42:33 pm »

And how to disable lighting?

Jonathan
Logged
jorrit
Administrator
Hero Member
*****
Posts: 1706


View Profile
« Reply #3 on: January 30, 2006, 04:06:54 pm »

And how to disable lighting?

Jonathan

You can add <lighting>no</lighting> in the params block of the mesh.

Greetings,
Logged
Pages: [1] Print 
« previous next »
Jump to:  

Powered by MySQL Powered by PHP Powered by SMF 1.1.2 | SMF © 2006-2007, Simple Machines LLC Valid XHTML 1.0! Valid CSS!
Page created in 3.385 seconds with 13 queries.