Crystal Space
Welcome, Guest. Please login or register.
October 24, 2014, 04:36:55 pm

Login with username, password and session length
Search:     Advanced search
9011 Posts in 2044 Topics by 8816 Members
Latest Member: Hejduczo
* Home Help Search Login Register
+  Crystal Space
|-+  Crystal Space Development
| |-+  Support
| | |-+  Segfault for CS 0.99 (pseudo-stable release) on Mac OS X 10.4.4
« previous next »
Pages: [1] Print
Author Topic: Segfault for CS 0.99 (pseudo-stable release) on Mac OS X 10.4.4  (Read 1725 times)
Loefty
Newbie
*
Posts: 3


View Profile Email
« on: January 31, 2006, 07:17:34 am »

Hi there.  I'm trying to compile CS and run the demos and get up to speed on everything.  I am looking to use CS for a game idea I have and perhaps contribute according to my skills.  I am running into issues though.  I've read the docs and believe I am doing things correctly.  I've search other topics and not found any help, so here I am posting.  Please feel free to point me in the right direction if I missed something obvious.

Here is all the pertinent data:

- Version of CS
0.99 (cs-pseudo-stable-2006-01-27.zip)

- Version of winlibs package (if on windows)
n/a

- Operating system
System Version: Mac OS X 10.4.4 (8G32)
Kernel Version: Darwin 8.4.0

- Compiler
powerpc-apple-darwin8-gcc-4.0.0 (GCC) 4.0.0 (Apple Computer, Inc. build 5026)

- Video card
Chipset Model: GeForce FX Go5200
Type: Display
Bus: AGP
VRAM (Total): 64 MB
Vendor: nVIDIA (0x10de)
Device ID: 0x0329
Revision ID: 0x00a3
ROM Revision: 2086

- Driver
OpenGL

Configured CS like so:

./configure --prefix=/Library/CrystalSpace --enable-debug

Built like so:

jam all

Got 1 build error like so:

MkDir1 ./out/macosxppc/debug/plugins/sndsys/renderer/software/drivers/coreaudio
C++ ./out/macosxppc/debug/plugins/sndsys/renderer/software/drivers/coreaudio/driver_coreaudio.o
plugins/sndsys/renderer/software/drivers/coreaudio/driver_coreaudio.cpp: In member function 'virtual bool csSndSysDriverCoreAudio::Open(csSndSysRendererSoftware*, csSndSysSoundFormat*)':
plugins/sndsys/renderer/software/drivers/coreaudio/driver_coreaudio.cpp:176: error: request for member 'Flags' in 'requested_format', which is of non-class type 'csSndSysSoundFormat*'

    g++ -c -o ./out/macosxppc/debug/plugins/sndsys/renderer/software/drivers/coreaudio/driver_coreaudio.o -I. -I./include -I./include -Wmost -Wno-unknown-pragmas -pipe -I/usr/local/include -Wno-long-double -force_cpusubtype_ALL -fno-common -fno-exceptions -fvisibility=hidden -Wno-non-virtual-dtor -g3 -DCS_DEBUG  plugins/sndsys/renderer/software/drivers/coreaudio/driver_coreaudio.cpp

...failed C++ ./out/macosxppc/debug/plugins/sndsys/renderer/software/drivers/coreaudio/driver_coreaudio.o ...
...skipped sndsyscoreaudio.csbundle for lack of <plugins!sndsys!renderer!software!drivers!coreaudio!>driver_coreaudio.o...
Copy sndsyscoreaudio.csplugin

End of build indicated such:

...failed updating 1 target(s)...
...skipped 1 target(s)...
...updated 1357 target(s)...

Tried to run the walktest and boom:

./walktest.app/Contents/MacOS/walktest flarge
Crystal Space for MacOS/X 0.99 r0 [MacOS/X-powerpc-GCC]
Ported to MacOS/X by Eric Sunshine <sunshine@sunshineco.com>

WARNING: could not load plugin 'crystalspace.font.server.freetype2'

crystalspace.system:
  World saving enabled.
  Crystal Space version 0.99 r0 [MacOS/X-powerpc-GCC] (Mon 7-Jul-2004).
  Created by Jorrit Tyberghein and others...

crystalspace.canvas.glosx:
  MacOS/X 2D OpenGL driver for Crystal Space 0.99 r0
Written by Matt Reda
  <mreda@mac.com>

crystalspace.canvas.openglcommon:
  OpenGL renderer: NVIDIA NV34MAP OpenGL Engine (vendor: NVIDIA Corporation)
  version 1.5 NVIDIA-1.4.18
  Using windowed mode at resolution 640x480.
  Pixel format: Color: 0 Alpha: 0 Depth: 0 Stencil: 0 AccumColor: 0
  AccumAlpha: 0 MultiSamples: 0
  WARNING! Crystal Space performs better in 24 or 32 bit display mode!
  Multisample: disabled

crystalspace.system:
  Loading map 'flarge'.
Load TYPE plugin crystalspace.mesh.object.emit
walktest(15539,0xa000ed68) malloc: ***  Deallocation of a pointer not malloced: 0x3926670; This could be a double free(), or free() called with the middle of an allocated block; Try setting environment variable MallocHelp to see tools to help debug
Segmentation fault

Please note that I have not installed CS to /Library/CrystalSpace, though that is my intention.  I have merely built it and tried running the walktest.

I did set my defaults for  "NSGlobalDomain CrystalSpaceRoot" to be the directory where I built CS.

Please let me know what more data I can provide.
Logged
rvl_
Newbie
*
Posts: 27


View Profile
« Reply #1 on: February 02, 2006, 09:01:20 pm »

https://sourceforge.net/tracker/index.php?func=detail&aid=1311220&group_id=649&atid=100649
Logged
Loefty
Newbie
*
Posts: 3


View Profile Email
« Reply #2 on: February 03, 2006, 04:32:24 am »

Lovely.  Thanks for the link.
Logged
Loefty
Newbie
*
Posts: 3


View Profile Email
« Reply #3 on: February 03, 2006, 05:42:10 pm »

For what it's worth, the OS X 10.4.4 dev tools (Xcode etc) should come with gcc-3.3 and gcc-4.0 by default.

Since there seems to be a problem with gcc-4.0 and CS, I just set my env vars like so before running configure and jam:


export CC=/usr/bin/gcc-3.3
export CPP=/usr/bin/cpp-3.3
export CXX=/usr/bin/c++-3.3


I was able to build CS successfully and can now run the walktest, no segfaults.

Thanks again.
Logged
Pages: [1] Print 
« previous next »
Jump to:  

Powered by MySQL Powered by PHP Powered by SMF 1.1.2 | SMF © 2006-2007, Simple Machines LLC Valid XHTML 1.0! Valid CSS!
Page created in 5.22 seconds with 16 queries.